Closed Bug 339547 Opened 16 years ago Closed 16 years ago

Pop-up blocking not working correctly

Categories

(Camino Graveyard :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 274143

People

(Reporter: a.c.li, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.3) Gecko/20060427 Camino/1.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.3) Gecko/20060427 Camino/1.0.1

On Friendster, when I clicked "Upcoming birthdays", a popup window appeared. I had all the anti-popup and anti-ad settings enabled in preferences, and no ad links were present near the link I clicked.

This has not happened with Firefox, even with Adblock (which interferes with Firefox's native ad-blocker) enabled.

Reproducible: Didn't try
You probably have single-window mode turned on in Firefox.

Please try this with a recent trunk nightly of Camino, with a fresh profile, after ensuring that "Single-window mode" is checked in the Tabs pref pane.

cl
Either way, this is almost certainly fixed with bug 274143.  If this still occurs after following the instructions in comment !, feel free to reopen this.

*** This bug has been marked as a duplicate of 274143 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
For the record, I did NOT enable single window mode, either in the MacOS X or the Linux version of Firefox. (Nor have I heard of such a mode before.)
I have looked up what "single window mode is", and, FWIW, I can quite confidently say that my bug has nothing to do with "single window mode", at least from a user's point of view.

Single window mode, as far as I can understand, means that if a link in a new window (either an intended open, or a pop-up ad) will always open in a new tab. My bug is different for two reasons:

1. Firefox's native ad-blocking completely prevents the link from opening the new window, rather than allowing the spam link to open in a tab. This differs from what "single window mode" does (as far as I can understand).

2. I have NOT configured Firefox to open everything in tabs. ("Force links that open new windows to open in" option is NOT set, neither on MacOS X nor on GNU/Linux.) Many links continue to open in new windows normally.

I have meanwhile downloaded Camino 1.0.2; I'll observe for a week or so to see if the problem still exists. (The problem occurs very frequently on Friendster, but not every time, so it will need some time for the problem to pop up, if it is still there.)
This is not in 1.0.x. Please test with a 1.8branch or trunk nightly, but this is still almost assuredly a dupe.

cl
To be clear, the *exposed* pref for SWM forces links into new tabs.  SWM is also able (via about:config) to force links which would open in new windows into the same tab (the behavior you requested and experienced under Firefox).
Sorry, please ignore my last 2 comments. I just found out that I have AdBlock installed on both Firefoxes. So this bug is invalid.

(But I still don't understand why ad-blocking has anything to do with single-window mode. Blocked windows do not get opened anywhere.)
You need to log in before you can comment on or make changes to this bug.