Richlistbox does not correctly report current item when navigating

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Jamie, Assigned: pilgrim)

Tracking

({access})

Trunk
All
Windows XP
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: Thunderbird: version 2 alpha 1 (20060529), Firefox: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a2) Gecko/20060525 BonEcho/2.0a2

In Tools->Options in Thunderbird and Firefox, the options page list (e.g. General, Display, Composition, etc. in Thunderbird) does not correctly report the active item via MSAA when navigating the list. Focusing on the list with tab or shift+tab correctly reports the active item. However, when using the up and down or left and right cursor keys, the item which was previously selected is reported as the active item.

Reproducible: Always

Steps to Reproduce:
1. Open the options dialog using Tools menu->Options.
2. The page list receives focus by default. Observe that the active item is reported correctly via MSAA.
3. Press down arrow. Observe that MSAA reports the active item as the same item as in step 2 (the previously active item), although its state has now changed to not selected. For example, if the active item in step 2 was 1, the active item will still be 1 (should be 2).
4. Press up arrow. Observe that the active item reported by MSAA is now the item that should have been reported in step 3. Given the examples in step 3, the active item reported by MSAA will be 2 (should be 1).
5. Press shift+tab and then tab to move the focus away from and back to the page list control. Observe that the active item reported by MSAA is correct. Given the above examples, this will be item 1.
Actual Results:  
When using the cursor keys, the active item is incorrectly reported by MSAA as the previously active item.

Expected Results:  
When using the cursor keys, the active item reported by MSAA should follow the actual active item.

Tested with JAWS for Windows and Narrator. An easy work around is to press shift+tab and then tab to have the active item reported correctly.

Comment 1

13 years ago
Dupe of bug 338234?

Comment 2

13 years ago
We have fixed some related bugs since 5/25 -- please verify with a recent build.
(Reporter)

Comment 3

13 years ago
This might be related to bug 338234, but that bug primarily describes issues when focusing on controls. In this case, the selected item is read correctly when focusing on controls, but not when the selected item is changed (e.g. with cursor keys). This does also apply for radio buttons. Still occurs with both the trunk and 2alpha builds for 20060605.

Updated

13 years ago
Assignee: aaronleventhal → pilgrim
Keywords: access
Summary: Options page list does not correctly report current item when navigating → Richlistbox does not correctly report current item when navigating

Comment 4

13 years ago
Is this a dupe of bug 338048?
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> Is this a dupe of bug 338048?
No, although I can also reproduce that bug. This bug relates to the active item being reported as the previously active item, whereas bug 338048 refers to an incorrect value being reported. There was some discussion in bug 338234 about focus events being issued for the previously active item instead of the currently active item, and in this sense, this is more similar to bug 338234. However, as noted in comment #3, this does not relate to focus, but rather, only to navigating while the control is focused.
(Reporter)

Comment 6

12 years ago
Fixed for me in Thunderbird version 2 alpha 1 (20060625) and Firefox Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060625 BonEcho/2.0a3. It probably was related to the fix for bug 338234, although the reported description and comments describe symptoms which are a little different as I explain in comment #3.
Hardware: PC → All

Updated

12 years ago
Blocks: 333488

Updated

12 years ago
Blocks: 335465
No longer blocks: 333488

Updated

12 years ago
Blocks: 335645
No longer blocks: 335465

Comment 7

12 years ago
Works for me from comment 6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.