Last Comment Bug 339653 - Breadcrumbs extension does not link all the pages tree as expected
: Breadcrumbs extension does not link all the pages tree as expected
Status: RESOLVED WORKSFORME
:
Product: Mozilla Developer Network
Classification: Other
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://developer.mozilla.org/es/docs/...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-30 00:19 PDT by Rubén Martín [:Nukeador]
Modified: 2012-09-18 23:12 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Rubén Martín [:Nukeador] 2006-05-30 00:19:23 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.0.3) Gecko/20060523 Ubuntu/dapper Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.0.3) Gecko/20060523 Ubuntu/dapper Firefox/1.5.0.3

When you use Breadcrumbs extension is expected to link all the previous page tree, but you only get a link to the main page.

Reproducible: Always

Steps to Reproduce:
1.Create a new page (ej.Wiki)
2.Create a subpage for the previous one (ej.Wiki:Help)
3.Add the Breadcrumbs extension in both pages
4.Save your changes

Actual Results:  
In Wiki page you get a link to the main page (Main > Wiki) but in the second one the Breadcrumbs extension does not work, you get (Main >Wiki:Help) instead of (Main > Wiki > Help)

Expected Results:  
You should get (Main > Wiki > Help) with links to each page instead of (Main > Wiki:Help).
Comment 1 Justin Wood (:Callek) 2006-05-30 01:37:52 PDT
taking bug, will investigate when Bug 311823 is complete.
Comment 2 Mike Shaver (:shaver -- probably not reading bugmail closely) 2006-05-30 05:19:31 PDT
How does this depend on the advanced syntax bug?

For the specific "Wiki:Help" case, I suspect it's because "Wiki" is a namespace in mediawiki, which means that it gets special treatment in the database.
Comment 3 Mike Shaver (:shaver -- probably not reading bugmail closely) 2006-05-30 05:29:01 PDT
Sorry, it's not a namespace, it's taken as an interwiki link.

Deb: do you think we need all the default interwiki entries here?  Seems like some of them ("Wiki" and "RFC", at least) are more likely to cause confusion than to be used for links to their respective sites.  We tend to prefer templates to interwiki stuff anyway, in most cases, too.
Comment 4 Mike Shaver (:shaver -- probably not reading bugmail closely) 2006-05-30 05:36:57 PDT
Oh, but of course the example in the comment uses "Wiki:", while the actual problem as linked from URL uses "MDC:", meaning that the example doesn't actually describe the same bug.  Ahem!

MDC: is a namespace issue, almost certainly.  Using Wiki: will likely slam up against interwiki issues at some point, though perhaps not in the breadcrumbs path.
Comment 5 Deb Richardson [:dria] (plz NEEDINFO) 2006-05-30 05:43:10 PDT
Regarding the "Wiki" thing -- could someone post/send me the full interwiki links list?  I suspect we can get rid of the vast majority of non-MDC related links.  Might as well clean that up as well.
Comment 6 Mike Shaver (:shaver -- probably not reading bugmail closely) 2006-05-30 05:49:48 PDT
I filed bug 339668 on the interwiki-cleanup issue.
Comment 7 Justin Wood (:Callek) 2006-05-30 17:23:14 PDT
I set it as depends because what I am doing in Bug 311823 will change (slightly) the way Breadcrumbs finds its parent.  I suspect that it might fix this, but am not sure yet.

If you intend to fix this sooner, or think my depend marking is wrong, feel free to remove the dependancy.
Comment 8 Nickolay_Ponomarev 2006-05-31 00:06:13 PDT
After that bug is fixed, one can use <breadcrumbs>[[MDC]]</breadcrumbs> to get correct breadcrumbs on [[MDC:Help]]. Do we really need anything else, given that we don't use namespaces that much?
Comment 9 Mike Shaver (:shaver -- probably not reading bugmail closely) 2006-05-31 08:49:58 PDT
(Nickolay: it's not clear from bug 311823 _what_ the new syntax or behaviour will be, though I still hope that someone will say so there, and soon.)

This doesn't require that advanced syntax to fix, necessarily, and there doesn't seem to be any activity in the advanced syntax bug to indicate that this would indeed be fixed by it, so I'm removing the dep.
Comment 10 Nickolay_Ponomarev 2008-11-03 11:01:16 PST
WFM with the switch to deki, since we don't have the breadcrumbs extension anymore.

Note You need to log in before you can comment on or make changes to this bug.