describecomponents.cgi doesn't show components of closed products, even when there are bugs in these products

RESOLVED FIXED in Bugzilla 3.2

Status

()

Bugzilla
User Interface
RESOLVED FIXED
12 years ago
4 years ago

People

(Reporter: timeless, Assigned: Frédéric Buclin)

Tracking

2.20.1
Bugzilla 3.2
Bug Flags:
approval +
approval3.4 +
approval3.2 +

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
steps:
1. use query.cgi and spot the derivatives product and its components
2. ask describecomponents for an explanation.

actual results:
 The product Derivatives does not exist or you don't have access to it. The following is a list of the products you can choose from. 

that's not true. while i might not be able to file bugs in deriviatives, i can see bugs in it. and if i can see bugs in it, i need to be able to read the descriptions of the components.

the rule being used by describecomponents is wrong.

note:
derivatives is closed for bug entry, but it isn't a product i'm not allowed to see, if it was, query wouldn't let me see it.
(Assignee)

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 311281 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

9 years ago
Oh, this bug actually still exists. Just hit me now in Bugzilla 3.5.
Status: RESOLVED → REOPENED
OS: Windows XP → All
Hardware: x86 → All
Resolution: DUPLICATE → ---
(Assignee)

Updated

9 years ago
Status: REOPENED → NEW
(Assignee)

Updated

9 years ago
Summary: bugzilla lied to me The product Derivatives does not exist or you don't have access to it. The following is a list of the products you can choose from. → describecomponents.cgi doesn't show components of closed products, even when there are bugs in these products
(Assignee)

Comment 3

9 years ago
Created attachment 378622 [details] [diff] [review]
patch, v1

If the product exists and the user is allowed to enter or search for bugs in it, then the product and its components should be described. I also added missing POD for get_accessible_products().

I leave my @products = @{$user->get_enterable_products}; at line 49 of describecomponents.cgi alone for now. The right fix is probably to pass a parameter to this script mentioning which products should be displayed (either enterable, selectable or accessible ones). But that's another bug.
Assignee: ui → LpSolit
Status: NEW → ASSIGNED
Attachment #378622 - Flags: review?(ghendricks)
(Assignee)

Updated

9 years ago
Target Milestone: --- → Bugzilla 3.2

Updated

9 years ago
Attachment #378622 - Flags: review?(ghendricks) → review+
(Assignee)

Updated

9 years ago
Flags: approval3.4+
Flags: approval3.2+
Flags: approval+
(Assignee)

Comment 4

9 years ago
tip:

Checking in describecomponents.cgi;
/cvsroot/mozilla/webtools/bugzilla/describecomponents.cgi,v  <--  describecomponents.cgi
new revision: 1.40; previous revision: 1.39
done
Checking in Bugzilla/User.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/User.pm,v  <--  User.pm
new revision: 1.187; previous revision: 1.186
done


3.3.4:

Checking in describecomponents.cgi;
/cvsroot/mozilla/webtools/bugzilla/describecomponents.cgi,v  <--  describecomponents.cgi
new revision: 1.39.2.1; previous revision: 1.39
done
Checking in Bugzilla/User.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/User.pm,v  <--  User.pm
new revision: 1.178.2.2; previous revision: 1.178.2.1
done


3.2.3:

Checking in describecomponents.cgi;
/cvsroot/mozilla/webtools/bugzilla/describecomponents.cgi,v  <--  describecomponents.cgi
new revision: 1.38.2.1; previous revision: 1.38
done
Checking in Bugzilla/User.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/User.pm,v  <--  User.pm
new revision: 1.164.2.5; previous revision: 1.164.2.4
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago9 years ago
Resolution: --- → FIXED

Updated

4 years ago
See Also: → bug 1032807
You need to log in before you can comment on or make changes to this bug.