Closed Bug 339733 Opened 14 years ago Closed 12 years ago

download manager does not ask for http auth credentials and set status to completed

Categories

(Toolkit :: Downloads API, defect)

1.8 Branch
x86
Windows XP
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 315227

People

(Reporter: kmdwac, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

When right-clicking on the link (e.g. Vorlesung1.pdf on the above-specified site) and selecting "Save Link As...", no prompt for entering username and password appears. It does appear when you left-click the link to open the file in the browser window.

Reproducible: Always

Steps to Reproduce:
1.Go to the above-specified website (http://tpc.physik.rwth-aachen.de/vorlesung/WS05/qi.phtml).
2. Right-click on "Vorlesung1.pdf"
3.Select "Save Link As..."

Actual Results:  
A dialog box opens asking where to save the file. After saving, try to open it with Adobe Reader. This fails, Adobe Reader tells you the file is damaged.

Expected Results:  
A prompt for username and password should appear before you are asked where to save the file.

With Mozilla 1.7.5, the problem does not occur.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.5.0.x Branch
No response from reporter re: comment 1 -->INCOMPLETE.
Reporter, if you still see this problem with the latest release of Firefox 2, please reopen this bug. Thanks!
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → INCOMPLETE
Thanks for looking at the problem and sorry for the late response. 

Unfortunately, the problem still occurs with Firefox 2.0.0.5.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
this is a problem with the download manager that does not ask for http auth before downloading, i think that this is a dupe, i have seen something related lately, but cannot find now

this is the reply from the server

HTTP/1.x 401 Authorization Required
Date: Sun, 29 Jul 2007 11:29:36 GMT
Server: Apache/2.0.46 (Red Hat)
WWW-Authenticate: Basic realm="PDF-Files"
Content-Length: 495
Connection: close
Content-Type: text/html; charset=iso-8859-1

the download manager then put the download status to "Done" instead of "Failed"

editing title, updating to 2.0 branch

On current Trunk the credentials are asked, but clicking CANCEL still reports "Done" instead of "Failed"

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072913 Minefield/3.0a7pre
Component: General → Download Manager
QA Contact: general → download.manager
Summary: Password-protected PDF files cannot be saved correctly to hard disk → download manager does not ask for http auth credentials and set status to completed
Whiteboard: CLOSEME 06/27
Version: 1.5.0.x Branch → 2.0 Branch
Whiteboard: DUPEME
Duplicate of this bug: 319305
i have created Bug 391645 for the problem on clicking CANCEL (see comment #4)

this is a Branch only bug, should this be resolved as WFM?
Whiteboard: DUPEME → CLOSEME?
fixed on trunk in bug 315227, won't be fixed on branch
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 315227
Verified dup
Status: RESOLVED → VERIFIED
Whiteboard: CLOSEME?
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.