Tab/shift+tab keys do not work in Search Messages window

RESOLVED DUPLICATE of bug 348263

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 348263
12 years ago
12 years ago

People

(Reporter: Jamie, Assigned: Scott MacGregor)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: version 2 alpha 1 (20060529)

In the Search Messages window, the tab and shift+tab keys do not move the focus forward and backward through controls as they should. These keys appear to have no effect at all.

Reproducible: Always

Steps to Reproduce:
1. Open the Search Messages window by pressing ctrl+shift+f or selecting Edit menu->Find->Search Messages.
2. Press tab. Repeat multiple times if you wish. Observe that the focus does not change.
3. Press shift+tab. Repeat multiple times if you wish. Observe that the focus does not change.
Actual Results:  
The focus does not change.

Expected Results:  
The focus should move to the next control when tab is pressed and to the previous control when shift+tab is pressed.

Bug 243124 describes the issue wherein an input field does not receive focus upon opening this window, but this is not the issue discussed here. Tab and shift+tab do function correctly in the Search Messages window in Thunderbird trunk builds.
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0
(Reporter)

Comment 1

12 years ago
Any chance of a fix for this before Thunderbird 2.0 is released? Imho, it is a pretty major accessibility issue and the fact that it works correctly in trunk suggests that there may already be a fix somewhere.

Comment 2

12 years ago
James, for TB2, this sounds like a dup of bug 348263. What do you think?
Severity: normal → major
Component: General → Mail Window Front End
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> James, for TB2, this sounds like a dup of bug 348263. What do you think?
Agreed.

*** This bug has been marked as a duplicate of 348263 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.