Error when opening calendar file with alarms

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: boris, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051115 Firefox/1.5 (pigfoot)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051115 Firefox/1.5 (pigfoot)

I have a remote calendar file which was created by the thunderbird calendar extension. I wanted to try lightning. After installing the latest lightning nightly (1-8-BRANCH) and restarting thunderbird I get very old alarm messages and an error (Calendar set to read only...):

[Exception... 
"'[JavaScript Error: "alarmTime has no properties" {file: "file:///.../extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calAlarmService.js" line: 332}]' when calling method: [calIObserver::onAddItem]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///.../extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calICSCalendar.js :: anonymous :: line 801"  data: yes]

Also nearly all topical entries and some todos are missing in the calendar.
I have no clue what makes my calendar so special that it produces this error, but it works without flaws with the calendar extension.

Reproducible: Always

Comment 1

13 years ago
Can you attach a testcase ics file containing a single event that shows this error?  Thanks.
This sounds like Bug 336766. Reporter, what version of Lightning do you use? Please also post the build id shown in extension manager.
(Reporter)

Comment 3

13 years ago
I have used the latest nightly build (Lightning 0.1+, build id: 2006060108). 

Since I don't know which entry in my calendar produces this error, I cannot make a simple test case.

Comment 4

13 years ago
(In reply to comment #3)
> Since I don't know which entry in my calendar produces this error, I cannot
> make a simple test case.
> 
Can you at least attach your whole calendar then?  We can't do much of anything without some idea of the ics that's causing this.

Comment 5

13 years ago
Any progress on a testcase here?

Updated

13 years ago
Summary: Error when openening calendar file with alarms → Error when opening calendar file with alarms

Comment 6

13 years ago
No testcase and insufficient info to reproduce.  Marking WFM.  If someone can provide more information to reproduce this bug they should re-open.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.