send mail window stuck, hung after sending

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: wsmwk, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060516 SeaMonkey/1.0.2

running SM 1.0.2 smoketests
clean profile
compose, send, message sent, compose message still there (didn't close)

compose window - all input fields are blocked (can't click address, subject or body) but all toolbar buttons are clickable and some menu items work ("find" for example). I can change "From" using drop down.  Attachments and body are right clickable

message sent successful, delivered OK to the destination account, and also appeared in the correct "sent" folder

I don't recall ever seeing a hung compose window like this.
(Reporter)

Comment 1

12 years ago
Created attachment 223943 [details]
screenshot
(Reporter)

Comment 2

12 years ago
not sure what's going on.
possibly a profile problem?
Keywords: smoketest

Comment 3

12 years ago
anything on the js console? Is this reproducible?
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> anything on the js console? Is this reproducible?

not sure about anything being there for I above - there are entries for lots of stuff.

...continuing my story...

I clicked "X" and it closed after prompt saying message had not yet been sent.  So maybe in saying it was delivered I confused this with a different message - doing too much at once.  THe screen shot however doesn't lie - somethere there is amiss.

HOWEVER, I closed and restarted suite - compose a message and send looks, it like it works bug doesn't, but no message at destination and there is a copy in "sent".

Comment 5

12 years ago
we only put a copy of the message in the sent folder *after* we've successfully sent the message to the smtp server, so if you're not getting the message at the destination, it's probably a delivery problem of some sort.

This isn't a smoketest blocker since it only happened once  (smoketest blocker is for bugs that block using the product at all)
Keywords: smoketest
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> we only put a copy of the message in the sent folder *after* we've successfully
> sent the message to the smtp server, so if you're not getting the message at
> the destination, it's probably a delivery problem of some sort.

OK, don't beat me too hard - my bug report is bogus.  I discovered the mail WAS sent. But the account on the PC I was monitoring for mail using thunderbird was hung since early this morning. I.E. it periodically doesn't receive new mail. 

HOwever, the condition in the screen shot is legit, but I can't explain it. The buttons clicked (for example send) but there was no response.  Have you ever seen anything like this?


> This isn't a smoketest blocker since it only happened once  (smoketest blocker
> is for bugs that block using the product at all)

That's not my read of the definition at https://bugzilla.mozilla.org/describekeywords.cgi but I trust your judgement.

Comment 7

12 years ago
sorry, didn't mean to beat on you - just wanted to limit the scope of what was going wrong.

I have seen that bug happen, but not in a long time. 

re smoketest blocker, I guess it's a gray area, but I don't think it's a smoketest blocker if it's not easily reproducible.
(Reporter)

Comment 8

10 years ago
haven't seen this in ages
=> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.