Bad title bar when Content-Disposition: inline; filename="xxx"

RESOLVED DUPLICATE of bug 224209

Status

()

Firefox
File Handling
--
minor
RESOLVED DUPLICATE of bug 224209
12 years ago
12 years ago

People

(Reporter: Ondrej Novy, Unassigned)

Tracking

1.5.0.x Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; cs; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; cs; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

When i use
Content-Disposition: attachment; filename="xxx" firefox gives me download dialg with save as xxx file
but if i use Content-Disposition: inline; filename="xxx" it shows document inline, but in window title bar is filename from address bar.


Reproducible: Always
Can you provide a link to a page which demonstrates this please?
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 2

12 years ago
http://ondrej.org/firefox/339938-attachment.php
http://ondrej.org/firefox/339938-inline.php

source:
attachment:
<?
header('Content-type: image/jpeg');
header('Content-Disposition: attachment; filename="image.jpg"');
readfile('test.jpg');
?>

inline:
<?
header('Content-type: image/jpeg');
header('Content-Disposition: inline; filename="image.jpg"');
readfile('test.jpg');
?>
Related to/dupe of bug #224209?
Component: General → File Handling
QA Contact: general → file.handling
(Reporter)

Comment 4

12 years ago
i think yes, but that bug is old and not fixed :)
(In reply to comment #4)
> i think yes, but that bug is old and not fixed :)
> 

That doesn't warrant filing a new bug.

*** This bug has been marked as a duplicate of 224209 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.