Closed Bug 339980 Opened 14 years ago Closed 12 years ago

Remove Add dictionary from Mac spellcheck context menu

Categories

(Firefox :: Menus, defect)

PowerPC
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 3 beta1

People

(Reporter: brettw, Assigned: dao)

References

Details

(Keywords: useless-UI)

Attachments

(1 file)

Once bug 151040 lands, we'll be using the system dictionary on Mac. We should then  remove the context menu for adding new dictionaries.
No longer blocks: SpellCheckTracking
Version: 2.0 Branch → Trunk
Forgive me if I'm wrong, but there seem to be dictionary language options for Firefox that aren't available in the OS X system. So someone stuck using a suboptimal system dictionary will still want to add the better Firefox dictionary, if available.

In my case, as far as I can tell there's no Australian English dictionary native to Mac OS X (Apple's Mail keeps telling me that "colour" is spelt wrongly), but there's is an add-on for Firefox.

I guess I can always add alternative dictionaries through the add-ons finder, but not all users will know that it can be done that way. Why remove the more obvious option? If anything, I'd suggest also adding it to Preferences, just under the spell-check option, to make it more intuitive.
Does bug 151040 add the OSX dictionary in addition to the Firefox dictionary, or does it replace that functionality? If it's additive, then I agree with Wayne, if it's replacing it, then this is indeed useless-ui - better would actually be to have the context menu item link to the "Spelling Preferences Panel" which is where OSX users can switch their dictionaries.
Bug 151040 ended up adding the OS X dictionary, not replacing the Firefox one, aiui. As a result, OS X users aren't using the system dictionary, though they probably should be. So, technically, this isn't useless UI yet, but would be if Firefox switched to the system dictionary.
(In reply to comment #3)
> So, technically, this isn't useless UI yet, but would be if
> Firefox switched to the system dictionary.

Only if the system dictionary is the only one a user would ever want. I've already presented one case where I believe this isn't true, I would guess there are more.
Sam, right now I'm only seeing one entry for my dictionary, not two, so did we actually add it? I'm a little confused.
(In reply to comment #5)
> Sam, right now I'm only seeing one entry for my dictionary, not two, so did we
> actually add it? I'm a little confused.

Sorry, I meant adding the backend. It is unused by Firefox. This bug should probably be WONTFIX at this point.
So, we have the backend support, but no actual front-end support? Clearing the blocking flag, but I think we *want* to use the OSX dictionary, so I'm now *very* confused.
Flags: blocking-firefox3?
(In reply to comment #7)
> So, we have the backend support, but no actual front-end support? Clearing the
> blocking flag, but I think we *want* to use the OSX dictionary, so I'm now
> *very* confused.

For Firefox 2, it was decided to use the non-native backend. I couldn't tell you why, though I could speculate things like "OS X doesn't have as many dictionaries available" and such. The OS X dictionary was hooked up by pink for Camino, but was written in a way that Firefox (or any Gecko consumer, really) could use it.

See: http://mxr.mozilla.org/mozilla/source/extensions/spellcheck/ and note myspell (which Firefox uses) vs osxspell.
Duplicate of this bug: 391124
From bug 391124:

Currently FF3 on mac is building OSXSpell, not myspell/hunspell. This means
that the "Get More Dictionaries" link is useless: even if you installed a
dictionary from AMO it would be useless.

We have a few options:
1) Build hunspell instead of OSXSpell
2) Make the "Get More Dictionaries" link provide a way to install new OSX
system dictionaries
3) Remove the "Get More Dictionaries" item on mac

This is a regression from FF2, which uses myspell.
Flags: blocking-firefox3?
Sorry, my comments earlier (see comment 1) were ignorant. There IS an Australian English dictionary in OS X (and many others I hadn't noticed)... it was just hidden.

Is it too much overhead to use OS X dictionaries by default, but still handle hunspell ones if the user wishes it? I can no longer think of an example where someone might want that, but perhaps it exists. But perhaps that's best left to an extension now.
Flags: blocking-firefox3? → blocking-firefox3+
Target Milestone: --- → Firefox 3 M10
A quick mxr search tells me that the code that references "spell-add-dictionaries-main" or "spell-language-separator" will work without it. "spell-add-dictionaries" doesn't seem to be referenced.
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #283283 - Flags: review?(mano)
Comment on attachment 283283 [details] [diff] [review]
remove the menuitems

r=mano
Attachment #283283 - Flags: review?(mano) → review+
Attachment #283283 - Flags: approval1.9?
Did we ever investigate whether there is an OS API for adding new dictionaries? IMO it would be much better to use that than to remove the menu item altogether.
I can't answer that question; I think it's rather unlikely but good stuff for a new bug in any case. I think the ifdefs are the right fix for the moment and removing them (as soon as there is a way to add dictionaries) would be a no-brainer.
Keywords: checkin-needed
Attachment #283283 - Flags: approval1.9?
Checking in browser/base/content/browser-context.inc;
/cvsroot/mozilla/browser/base/content/browser-context.inc,v  <--  browser-context.inc
new revision: 1.34; previous revision: 1.33
done
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: Firefox 3 M10 → Firefox 3 M9
Is there a bug somewhere that made us use osxspell? Given that we're using hunspell now, which is linguistically superiour to myspell, I wonder if we should reconsider that decision.
(In reply to comment #17)
> Is there a bug somewhere that made us use osxspell?

I think it was the combination of bug 151040, bug 339106 and (maybe?) bug 326469.
It seems that bug 343535 might evolve into "evaluate osxspell vs hunspell independently of cocoa".
Verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007100904 Minefield/3.0a9pre. The "Add dictionary" option is no longer available from the context menu on the Mac.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.