[accessiblity] no way to do "Don't Save" from the keyboard (but I can do "Cancel" and "Save")

RESOLVED DUPLICATE of bug 207510

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 207510
12 years ago
9 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

Trunk
Thunderbird1.5
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

[accessiblity] no way to do "Don't Save" from the keyboard (but I can do "Cancel" and "Save")

blake (mr super mac) pointed this out.
OS: Mac OS X 10.3 → Mac OS X 10.4
Target Milestone: --- → Thunderbird1.5
Created attachment 224105 [details]
here's the dialog that I can't dismiss without using the mouse
thanks to mr. b mac for pointing this out to me at Macworld.
on windows, I can tab to go from save, don't save an cancel.

Comment 4

12 years ago
On Windows, there's also an accelerator: Alt+D will select Don't Save.
Under Win2K, the D is always underlined; but I think maybe under XP, the underlines don't appear until the Alt is pressed (?).  Anything similar under the Mac?
>but I think maybe under XP, the underlines don't appear until the Alt is pressed (?)

on windows xp, I see the underlines that you described (even when I don't press the alt key).

I'll have to check my mac and see.
> Anything similar under the Mac?

nothing like this on the mac.  

this seems like an accessibility issue with mac os x to me, and that we should have this with other multiple button prompt dialogs, right?

(Maybe josh knows.)
QA Contact: front-end

Updated

10 years ago
Assignee: mscott → nobody

Comment 7

9 years ago
Ctrl-D works, BTW.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 207510
You need to log in before you can comment on or make changes to this bug.