Bookmarks in Old Folder Destroyed Using Copy, Cut, Paste and Undo to Other Folders

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: bobk4653-tech, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

Hi, 

I found the following problem with the bookmarks manager using Firefox version 1.5.0.3.

Basically, I was doing copy, cut, paste and undo functions from/to folders and it blanked out the original bookmarks that were selected and copied. To duplicate the issue without having an adverse effect on your original bookmarks.  In other words, don't initially to copy bookmarks from another folder. 


Reproducible: Always

Steps to Reproduce:
1) Start Firefox 

2) Select Bookmarks-> Manage Bookmarks 

3) Create an 'Old' folder and click OK

4) Create two bookmarks in the Old folder (i.e. this represents one of your old folders before you get started on this adventure). Note: Old could be one of your original folders, but I'm a nice guy and wouldn't want to mess up your original prescious bookmarks like I did.  

5) Now, close and reopen Firefox

6) Select Bookmarks-> Manage Bookmarks 

7) Create a 'CutFrom' folder and click OK 

8) Create a 'CopyTo' folder and click OK 

9) Select the 'Old' folder in the left pane 

10) Select Bookmarks and then Old in the left pane

11) In the right pane, select both bookmarks using Ctrl and clicking the left mouse button 

12) Type Ctrl-C and Ctrl-V to create a duplicate set of bookmarks in the Old folder

13) Select the duplicates using Ctrl and clicking the left mouse button 

14) Drag and drop the selected duplicates to CutFrom

15) Select CutFrom in the left pane 

16) Select the two bookmarks using Ctrl and clicking the left mouse button 

17) Type Ctrl-X

18) Select Bookmarks in the left pane and CopyTo folder in the right pane

19) Type Ctrl-V to paste the bookmarks

20) Select Edit-> Undo until Undo becomes grayed out 

Actual Results:  
The Old folder has two empty bookmarks in it. I didn't expect anything to happen to it since I used the copy (Ctrl-C) command to duplicate the bookmarks and use them somewhere else. 


Expected Results:  
I expected to see is an Old folder with its original bookmarks and the CutFrom and CopyTo folders to disappear using the Undo command. 


Now, the reason I was doing the was to be able to copy and paste bookmarks from one folder to another.  Intuitively, I expected to create a duplicate list of bookmarks in another folder.  However, functionally, it does two odd things:   

 - First it pastes the copied bookmarks in the root and not the folder I selected in the right pane (non-intuitive behavior) 
 
 - Second it blanks out the bookmarks in the original folder (bug)

Cheers, 
Bob K.

Comment 1

12 years ago
Probably fixed by bug# 168411 in FireFox2 and not security related.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.