mail headers marked as junk will be deleted if opened

RESOLVED DUPLICATE of bug 287728

Status

--
critical
RESOLVED DUPLICATE of bug 287728
13 years ago
11 years ago

People

(Reporter: stephen.schulte, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: version 1.5.0.2 (20060308)

I have the following mail filters running to automatically move mail flagged as junk into my junk folder.
X-Header-Overseas
X-Header-NoReverseIP
X-Header-Maps
I also the mail client set to fetch headers only and delete mail from server only after I delete or move them from the inbox.

Anyhow, my filter sometimes flags legitimate mail and drops it into the junk folder. When I try to open the mail by double clicking on the link that says:

"Only the headers for this message were downloaded from the mail server.

Click here to download the rest of the message. " 

The email is automatically deleted, with no warning.
 

Reproducible: Sometimes

Steps to Reproduce:
1.open junk mail folder, Select mail that flagged as junk and click the " THIS IS NOT JUNK" button

2.Move the file back into your inbox.

3.Then click on link in the message pane that says: "Click here to download the rest of the message. "

Actual Results:  
message is deleted without downloading content of message.

Expected Results:  
message should be downloaded and contents of message should be displayed in message body pane.

Comment 1

12 years ago
(In reply to comment #0)
> I have the following mail filters running to automatically move mail flagged
> as junk into my junk folder. [...]

This is confusing.  Is your filter marking messages with those headers as junk, or moving messages with those headers to the Junk folder?  Is the problem with messages that have been moved (or marked as junk) by your filter, or messages that have been detected as junk and moved according to the setting in the Junk Mail Controls?


> I also the mail client set to fetch headers only and delete mail from server
> only after I delete or move them from the inbox.

If you're going to use headers-only, it would probably be safer to turn off that "after I delete or move them from the inbox" setting entirely.  The whole leave-on-server/delete-from-server feature is not flexible and wasn't designed for headers-only operation (which was added much later).
(Reporter)

Comment 2

12 years ago
sorry, for any cunfusion caused by my bad grammar. 

>This is confusing.  Is your filter marking messages with those headers as junk,
>or moving messages with those headers to the Junk folder?  Is the problem with
>messages that have been moved (or marked as junk) by your filter, or messages
>that have been detected as junk and moved according to the setting in the Junk
>Mail Controls?

My filters move the headers that match into the junk folder. When I find a message in the junk folder that shouldn't be there. I try to open it, that is  when the issue appears.

I have noticed that when retreiving the rest of the mesasge there momentarily will be a duplicate of the message header in the inbox, but then the original instance (with just the header info) is removed to make way for the updated instance ( with the entire message). Is it possible that reference to the original and the new is not getting updated and thus causing both instaces to be deleted on clean up?  

 As for whether the junk mail control, is contributing to the issue, I can't say. I haven't been using the junk mail controls or the adaptive filter. However, I will enable junk mail logging and try to determine if both the custom filter and the junk mail control are flagging the same item.

>If you're going to use headers-only, it would probably be safer to turn off
>that "after I delete or move them from the inbox" setting entirely.  The whole
>leave-on-server/delete-from-server feature is not flexible and wasn't designed
>for headers-only operation (which was added much later).

I had decided to use this setting after logging this issue. It has prevented the loss of mail.

If there is something else I can do to provide more info to help isolate this issue let me know.

Comment 3

12 years ago
I think this may be a dupe of bug 248742.

Comment 4

12 years ago
which is also the same as bug 287728
QA Contact: front-end

Comment 5

12 years ago
Is this still reproducible with TB 2.0?

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 287728
You need to log in before you can comment on or make changes to this bug.