Phantom Scrollbars appear after clicking on another program in the dock

RESOLVED FIXED in mozilla1.8.1beta1

Status

Core Graveyard
Widget: Mac
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: marcia, Assigned: Mark Mentovai)

Tracking

({fixed1.8.1})

1.8 Branch
mozilla1.8.1beta1
PowerPC
Mac OS X
fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Seen using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a3) Gecko/20060531 BonEcho/2.0a3

STR:

1. I was using Yahoo Mail and scrolling through a long message. I replied to the message and returned to my inbox.
2. I clicked on the edge of another program in the dock (in this case it was the Mozilla icon)
3. A phantom scrollbar appears on the page in the very same place it was on the previous page.

Screenshot to follow
(Reporter)

Comment 1

12 years ago
Created attachment 224128 [details]
particularly ugly rendition of the problem
(Assignee)

Comment 2

12 years ago
Looks like this was caused by bug 54488.
Assignee: nobody → mark
Blocks: 54488
Component: General → Widget: Mac
Product: Firefox → Core
Target Milestone: --- → mozilla1.8.1beta1
Version: 2.0 Branch → 1.8 Branch
(Assignee)

Comment 3

12 years ago
Created attachment 224141 [details] [diff] [review]
Patch
Attachment #224141 - Flags: review?(joshmoz)

Updated

12 years ago
Attachment #224141 - Flags: review?(joshmoz) → review+
(Assignee)

Updated

12 years ago
Attachment #224141 - Flags: approval-branch-1.8.1+
(Assignee)

Comment 4

12 years ago
Checked in on trunk and MOZILLA_1_8_BRANCH for 1.8.1b1.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
(Assignee)

Comment 5

12 years ago
FYI, the scrollbars were hanging around after the document was no longer displayed because of the bfcache.

Updated

9 years ago
Component: Widget: Mac → Widget: Mac
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.