Clicking Middle Button (autoscroll) in Mail Window has Wrong Directional Pointer

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Rodney Persky, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.2)
Build Identifier: version 1.5.0.4 (20060516)

When clicking in the mail window with the middle button (scroll wheel) I occasionally will get the wrong directional arrow setup. Look at image that is linked to this message.

Reproducible: Sometimes

Steps to Reproduce:
1. Have Mail with Horizontal and vertical scroll bar (or only vertical, not tested on horizontal only)
2. Middle Click
3. You may get the wrong directional arrow (70% of the time)

Actual Results:  
The directional arrow does not represent actual options I.E. All 4 directions when only 2 are present and vica versa... although it does scoll all directions even though it only shows 2

Expected Results:  
The software should represent the actual state of the scroll bars

Default Theme, Default Options (Mozilla Thunderbird)

Comment 1

12 years ago
Confirming based on screenshot.  (Is there a name for this type of scrolling other than 'middle click scroll'?)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Clicking Middle Button in Mail Window has Wrong Directional Pointer → Clicking Middle Button (scroll) in Mail Window has Wrong Directional Pointer

Comment 2

11 years ago
Rodney. Are these html messages or plain text?  What version of TB (from help|about)?


(In reply to comment #1)
> Confirming based on screenshot.  

If this is seen in thunderbird shouldn't Rodney also see it in a mozilla based browser with the same version of gecko?  I can't confirm this behavior - it's WFM with thunderbird trunk.  some other references: bug 20618, bug 293872, bug 298939, bug 72747 (which created several regressions, now long since fixed)

If this turns out to be a legit bug perhaps Martijn from bug 212002 can help.


>Is there a name for this type of scrolling other than 'middle click scroll'?

autoscroll.  also known as 4-way scroll, panning and universal scroll. (geez, enough names to be a street drug)  nicely described as 
 "ability to make your page scroll automatically. Speed and scrolling direction 
  are controlled by the mouse pointer position relative to the initial marker."
at http://perso.orange.fr/marc.boullet/ext/extensions-en.html 
Summary: Clicking Middle Button (scroll) in Mail Window has Wrong Directional Pointer → Clicking Middle Button (autoscroll) in Mail Window has Wrong Directional Pointer

Comment 3

11 years ago
I can reproduce this still with 1.5.0.9, but my 2b2 build works correctly.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.