add (hidden) option to disable keyboard shortcuts for the bookmark bar

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
13 years ago
9 years ago

People

(Reporter: mg_list, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; chrome://navigator/locale/navigator.properties; rv:1.9a1) Gecko/20060501 Camino/1.2+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; chrome://navigator/locale/navigator.properties; rv:1.9a1) Gecko/20060501 Camino/1.2+

Although some people may like it I don't see much sense in having fixed keyboard shortcuts for the bookmark bar. I'd rather would add an option to add customizable keyboard shortcuts to specific bookmarks.

Anyway: Years ago I reconfigured my menubar in order to use Command-1 and -2 to toogle tabs. With the newly added keyboard shortcuts for the bookmark bar those commands do not work anymore.

I see two workarounds: Either don't open the bookmark when a menu entry with the same shortcut exists or add (at least a hidden) option to disable this feature.

Reproducible: Always

Steps to Reproduce:
1. Use the keyboard pref pane to reassign command-1 to a Camino menu entry
2. Launch Camino and press command-1
Actual Results:  
The first bookmark from the bookmark bar is openend

Expected Results:  
The assigned menu entry should be executed.

Comment 1

13 years ago
I can see the merit here (especially since we over-ride the os's customization settings), but I'm not sure enough people would benefit to justify a pref.

Comment 2

12 years ago
WONTFIX per pinkerton.

Safari has the same problem. That's not an excuse in and of itself, but the reason it has the same problem is because there's no easy way to prevent the browser from taking over that keyboard shortcut.

Adding a pref to disable a feature that literally hundreds of people have requested is simply not worth our time. Sorry, Martin.

cl
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

12 years ago
I just played around with a recent nightly build and discovered that Camino does not only react on "command-#" but also on "command-ctrl-#" and command-option-#". As these serve no special purpose I like to suggest to forward these commands to the OS in order to activate menu entries - this would solve my problem.

Comment 4

9 years ago
(In reply to comment #3)
> I just played around with a recent nightly build and discovered that Camino
> does not only react on "command-#" but also on "command-ctrl-#" and
> command-option-#". As these serve no special purpose I like to suggest to
> forward these commands to the OS in order to activate menu entries - this would
> solve my problem.

I know this is three and a half years late, but the bug described in this comment and in comment 1 *should* be fixed now. I don't know that it was ever explicitly filed, but the code has been modified so that if a Command-# shortcut is assigned elsewhere, it should win over the (default and hidden) bookmarks shortcuts.

If that's still failing to happen in some cases, please do file a new bug describing the problem in detail.
You need to log in before you can comment on or make changes to this bug.