Removing profile with profile manager DELETES other data in folder where it was

RESOLVED DUPLICATE of bug 270705

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 270705
13 years ago
13 years ago

People

(Reporter: borislavdj, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

I have used the "firefox.exe -profilemanager" to create a profile "Borislav Firefox profile" for saving my profile for backup purpose. I have choosed to backup it to my "E:/Install" folder, and I did it without making aditional subfolder. It made some folders (Cache, bookmarkbackup...) and its files.
Later, I used the profile manager to remove it from the "E:/Install" folder and to make a subfolder. Later, I have realised that the profile was removed TOGETHER WITH 800MB OF MY PRIVATE DATA AND DOCUMENTS! 

Reproducible: Always

Steps to Reproduce:
1.Run "firefox.exe -profilemanager" and create profile to custom directory
2.Run that profile
3.Turn of Firefox
4.Run "firefox.exe -profilemanager" and remove that profile

Actual Results:  
In "E:/Install" I have lost:
"Starter Pack" folder sized about 600MB,
"Rezanje" folder containing about 50-100MB of bussines documents
"WINXP" folder with xpsp2, drivers, tools etc.
DISASTER !!!!

Expected Results:  
Just delete its (PROFILE) files and folders, NOT THE PRIVATE DATA!!! Its a time and money loss.

WHO WILL MAKE IT BACK TO ME NOW?

I have tried to recover data with no success. I have worked meanwhile and overwrited space that was cleared on hdd before. I have tried later to make those folders with same names and it happend once more!!! It was a Risk to do it again. I have a screenshot from recovery software that shows deleted folders and files.

Now, what about my data? It is 1/4 year work! Its a time and money loss.

Specs: FSC Amilo 1667g notebook, 100gb hdd (E:\ - NTFS partition, 66GB), WinXP Home edition with sp2, Firefox 1.5.0.4

*** This bug has been marked as a duplicate of 270705 ***
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
bug 302087 (inadequate warning -- though at least the fi l10n for 1.5.0.3 seems reasonably clear to me in specifying the folder and that it will be irrevocably deleted if that button is pressed), bug 305551 (prevent creating profile in an existing folder in the first place), bug 331810 (try to guess what files are mozilla profile files and leave unrecognized files in place)
You need to log in before you can comment on or make changes to this bug.