Bookmarks Toolbar button stays in "pressed" state after a drag and drop

RESOLVED DUPLICATE of bug 225434

Status

()

Firefox
Toolbars and Customization
--
minor
RESOLVED DUPLICATE of bug 225434
12 years ago
10 years ago

People

(Reporter: Israel Rios, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.13) Gecko/20060418 Firefox/1.0.8 (Ubuntu package 1.0.8)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.13) Gecko/20060418 Firefox/1.0.8 (Ubuntu package 1.0.8)

When a bookmarks toobar button is dragged and dropped, it remains in pressed state after the mouse button have been released.

Reproducible: Always

Steps to Reproduce:
1. Drag a bookmarks toolbar button and drop it at some place outside the toolbar or at it same position;
2. Move the mouse pointer to the same button again.

Actual Results:  
The button is displayed as when it is pressed.

Expected Results:  
The button should be displayed as not pressed when the mouse button is not pressed in it.
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060602 Minefield/3.0a1 - Build ID: 0000000000
Confirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

Comment 2

12 years ago
I reproduced this on Windows with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060826 Minefield/3.0a1

changing OS to ALL.
OS: Linux → All

Comment 3

12 years ago
Same in 2.0b2 and the yesterdays nightly, only the bookmark looks pressed when it is hovered over with the cursor. Stops being so if a tab is closed.

Comment 4

12 years ago
Addition:

Firefox 2.0 tested in suse linux 10.0/10.1 and windows xp sp2.

If a bookmark button is clicked and the mouse is dragged away from the button before releasing the click; it causes the button to appear "pressed" when it is moused over until reclicked.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 225434
You need to log in before you can comment on or make changes to this bug.