Closed Bug 340155 Opened 16 years ago Closed 16 years ago

Right clicking on bookmarks contained within a folder on the bookmark toolbar, doesn't bring up more options, it simply visits the site!

Categories

(Firefox :: Bookmarks & History, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 300710

People

(Reporter: richard, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

If you create a bookmark on the bookmark toolbar itself, you are able to right click it and select options such as, "Open", "Properties" etc. Especially useful if you want to rename your bookmark. The issue is that if you try do the same thing to a bookmark contained within a bookmark folder, mozilla simply opens the website pointed to the bookmark and stops there.

Reproducible: Always

Steps to Reproduce:
1. Create a bookmark folder on the bookmark toolbar.
2. Drag one of your existing bookmarks into the folder.
3. Attempt to right-click (control-click) on the item in the bookmark folder.

Actual Results:  
Firefox visited the website pointed to by the bookmark.

Expected Results:  
A sub menu should pop up with options such as, "Open", "Properties", "cut", "copy"  etc.
Unfortunately, that's just the way it's supposed to be: right clicking a Mac native menu item fires the menu item's command, just like left clicking it, and folder menus imitate menus.

*** This bug has been marked as a duplicate of 300710 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.