Autoconfig Proxy hangs Camino regardless of System Preferences

RESOLVED WORKSFORME

Status

defect
--
critical
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: jch, Unassigned)

Tracking

({qawanted})

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; chrome://navigator/locale/navigator.properties; rv:1.9a1) Gecko/20060531 Camino/1.2+ (camino.undo.it)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; chrome://navigator/locale/navigator.properties; rv:1.9a1) Gecko/20060531 Camino/1.2+ (camino.undo.it)

Using the default configurations, Camino will hang shortly after 

"2006-06-02 20:04:36.768 Camino[17025] Using Proxy Auto-Config (PAC) file http://proxy.lib.berkeley.edu:7777/proxy.pac"

is shown in console.log (~5 to 10 seconds after startup).  Going into System Preferences and turning off autoconfig while Camino is hung will make Camino responsive again.

Using the instructions listed at http://www.caminobrowser.org/support/docs/proxy/#configure_pac to hard code proxy settings also results in camino hanging.

Reproducible: Always

Steps to Reproduce:
1. start camino (with system prefs autoconfig = http://proxy.lib.berkeley.edu:7777/proxy.pac and camino.use_system_proxy_settings = true)
2. hangs after read system prefs
3. similar results when manually setting configuration in user.js



Expected Results:  
A login page.  Safari did not have trouble with this.

I found some information at "http://forums.mozillazine.org/viewtopic.php?t=387505&highlight=&sid=801f31a81e5d6f830d96434963f8245c"

which sounds identical to my problem.  However, manually settings the preferences in user.js as suggested did not work for me.
Does this work properly with an official trunk nightly?

cl
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Does this work properly with an official trunk nightly?
> 
> cl
> 

I just got the nightly.  The same thing happens.  I tried both manually setting the configs in user.js as well as using the default system prefs version.
Jerry, does Camino ever recover (if you let it wait a minute or so)?  Or if you start with a fresh profile?

This sounds not unlike bug 327452.
Jerry, could you respond to comment 3 please?
Whiteboard: [CLOSEME 6/18]

Comment 5

13 years ago
(In reply to comment #3)
> Jerry, does Camino ever recover (if you let it wait a minute or so)?  Or if you
> start with a fresh profile?
> 
> This sounds not unlike bug 327452.
> 

Sorry for the slow reply.  I did see bug 327452 when I was initially searching, but I have this problem with a fresh profile.  Hence, I believe that Camino hangs not because of preferences, but specifically when it attempts to read pac configuration from System Preferences.  I tried deleting my configuration files after running as well.  Also, Camino doesn't necessarily need to hang on launch.  It can hang whenever the autoconfig setting is changed to read from System Preferences.  Currently, my solution is to set 'read from system prefs' to false.
A fresh profile will still try to load favicons.

Can you elaborate more on "It can hang whenever the autoconfig setting is changed to read from System Preferences."  (I wonder if that's bug 327599?)

Comment 7

13 years ago
(In reply to comment #6)
> A fresh profile will still try to load favicons.

I don't see the relation with the proxy autoconfig along with favicons.  Could you please explain.

> Can you elaborate more on "It can hang whenever the autoconfig setting is
> changed to read from System Preferences."  (I wonder if that's bug 327599?)

Rather than having Camino freeze only at startup, I can make it freeze when 'read autoconfig proxy from system prefs' is set to true, and I activate System Prefs -> Network -> Airport/Ethernet settings -> Automatic Proxy Configuration.

Comment 8

13 years ago
Regression range?  Does this happen in the 1.8.0/1.0 or 1.8/1.1 series too?

Updated

13 years ago
Whiteboard: [CLOSEME 6/18]

Updated

13 years ago
Keywords: qawanted
Jerry, can you please respond to comment 8?

cl
Closing WFM due to lack of updates.  If this problem still exists in Camino 1.1b or a recent nightly and you can supply the requested additional information, you may reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 11

11 years ago
Hello, I'd like to reopen this bug. This problem still exists in Camino 1.5.5 and 1.6b2.

Reproducible: Always

Steps to Reproduce:
1. start camino with Proxy Auto-Config disabled
2. open some 5 tabs with wikipedia, news.google.com and news.yahoo.com
3. in prefs check "load pages that were open before quitting"
4. quit camino
5. use the following Proxy Auto-Config file (I have squid running for testing purposes on localhost):
function FindProxyForURL(url, host) {
  return "PROXY 127.0.0.1:3128";
}
6. start camino

Using the Proxy Auto-Config file, Camino will hang shortly after startup while loading the tabs that were open before quitting.

At first Camino was not responding anymore and I had to force quit it (I try to attach several "sample files" recorded by Activity Monitor). After removing the profile and starting with a fresh one I couldn't reproduce the freeze anymore. However, Camino now hangs for several minutes while progress indicators of (some of) the tabs are spinning and "Loading..." is indicated in the status bar. CPU usage is normal. After a while Camino will become responsive again. Same result if I hardcode the pac file in the hidden configuration (user.js).

For those in need to reproduce the error without a proxy server try the following pac file. Doesn't work either. Actually takes even longer for the tabs to load. And finally I get this message: "Address Not Found: Camino could not find the host server for the provided address."

function FindProxyForURL(url, host) {
  return "DIRECT";
}

floh
Is this the same as bug 351678 (which is our currently-open proxy bug)?

Comment 16

11 years ago
Apparently yes and no. No in that it is not related to bookmarks. Yes because it seems to be related only to the pac file digestion. Might also be the same as bug 327452. After reading the other bug report, I noticed that the same problem was reported to the core as early as 2001 (bug 100022). It was finally fixed in Firefox in 2005. I suppose a developer can reproduce the error in a few minutes even without using a proxy server (see example above) in order to confirm my guesses. How can I help?
You need to log in before you can comment on or make changes to this bug.