Closed Bug 340249 Opened 14 years ago Closed 14 years ago

Tools -> Options -> Content -> Colors - Dialog box is not wide enough to display everything.

Categories

(Firefox :: Preferences, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 283697

People

(Reporter: chuckr, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060603 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060603 Minefield/3.0a1

Accessing Tools->Options->Content->Colors presents a dialog box that is not wide enough and ends up cutting off part of the "Link Colors" section.

This may be due to me using a custom Windows XP Theme, as I have occasionally seen applications not take font selections into consideration.  I don't, however, see this problem happening with any other dialogs in Minefield.

Reproducible: Always

Steps to Reproduce:
1. Use a custom Windows XP theme that involves a change in font/size.
2. Open Tools -> Options -> Content -> Colors

Actual Results:  
The dialog window is too narrow and cuts off part of the "Link Colors" section.

Expected Results:  
Dynamically sized itself.

Screen shot:

http://www.gsgc.org/images/ColorsBug.png

The Windows XP Theme I'm using:

http://www.gsgc.org/images/MainTheme.Theme
Severity: trivial → normal
Version: unspecified → Trunk
Options menu could be resizeable.
I found an easier way to reproduce this bug on the latest trunk build (although on the newer trunk builds I only see this bug appear under the security tab).

Reproducible: Always

Steps to Reproduce:
1. Goto Control Panel, click Display
2. Select the Appearance Tab
3. Using any XP theme select "Large" or "Extra Large Fonts" under font size.
4. Run trunk build and go into Tools -> Options -> Security

Actual Results:
The dialog window is bigger although the Warning Messages section is cut off.

Expected Results:
Dynamically sized itself although with no content cutting off.

Confirmed with Windows XP Classic, Luna and Royale themes.
Used Windows XP Royale theme with Extra Large Fonts being used.

*** This bug has been marked as a duplicate of 283697 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.