nsAccessible::GetXULName ought to recognize that the labels are invisible and skip over them

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: rstrong, Assigned: aaronlev)

Tracking

({access})

Trunk
mozilla1.8.1beta2
x86
Windows XP
access
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Updated

13 years ago
Assignee: aaronleventhal → pilgrim
(Assignee)

Updated

13 years ago
Keywords: access
Requesting blocking 1.8.1 since this blocks Bug 335645 and bug 338048 which also blocks Bug 335645.
Flags: blocking1.8.1?

Updated

13 years ago
Flags: blocking1.8.1? → blocking1.8.1+
--> beta2
Target Milestone: --- → mozilla1.8.1beta2
(Assignee)

Updated

13 years ago
Assignee: pilgrim → aaronleventhal
(Assignee)

Comment 3

13 years ago
We do check visibility. See
http://lxr.mozilla.org/seamonkey/source/accessible/src/base/nsAccessible.cpp#1304

The richlistitem bugs are actually caused by the richlistitem GetLabel implementation which is used when nsIDOMXULSelectControlItemElement is supported
http://lxr.mozilla.org/seamonkey/source/accessible/src/base/nsAccessible.cpp#1630
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
The original cause as stated in bug 338048 comment #1 was incorrect and a new bug was opened for the actual cause - see bug 338048. I also requested blocking on bug 338048.
(Assignee)

Comment 6

13 years ago
No, it's not a bug.
Flags: blocking1.8.1+
You need to log in before you can comment on or make changes to this bug.