Xulrunner does not display text (listitem label) in listbox when using transparent window (background:transparent)

RESOLVED DUPLICATE of bug 340284

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 340284
12 years ago
10 years ago

People

(Reporter: edwardbaafi, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla Xulrunner 1.8.0.1 Developer Preview Release, 1.8.0.4 (latest nightly) & 1.9a1 (recent build - nightly's out of date) 

Running xulrunner in transparent window mode (window style="background:transparent;") causes listitem label text not to appear within the listbox.. This also occurs with richlistbox elements as well.. 

Reproducible: Always

Steps to Reproduce:
1. Execute xulrunner.exe with application.ini pointing to following xul fule:

<?xml version="1.0"?>
<?xml-stylesheet href="chrome://global/skin/" type="text/css"?>
<!DOCTYPE window>
<window title="ListBoxTest"
        style="background:transparent;"
        xmlns:html="http://www.w3.org/1999/xhtml"
        xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
        width="400"
        height="250">

<listbox id="someList">
<listitem label="Label1"/>
<listitem label="Label2"/>
<listitem label="Label3"/>
</listbox>

</window>

Actual Results:  
Blank listbox appears with no text..

Expected Results:  
Listbox should appear with Label1, Label2, and Label3 on three lines within listbox..  (Remove style="background:transparent;" for expected results)
(Reporter)

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 340284 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.