toolbar background image not being painted / tiled fully

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
normal
VERIFIED WORKSFORME
18 years ago
7 years ago

People

(Reporter: Jus, Assigned: dcone (gone))

Tracking

Trunk
All
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
When the browser is first started the backgound on the toolbar around the
foward,back button etc. is only partially displayed. If the mozilla homepage is
loaded a black line appears through the middle of the mozilla banner. These
graphics gliches persit even if the browser is moved.
Everything goes back to normal when the browser is minimised and the restored.

Comment 1

18 years ago
-> XPToolkit Widgets

COnfirmed with win32 builds under 98 and NT from 3/29 and 3/30
Assignee: cbegle → trudelle
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Toolkit/Widgets
Ever confirmed: true
QA Contact: asadotzler → jrgm

Comment 2

18 years ago
The background-image is not being painted/tiled on the initial load of the 
<toolbar>. The same XUL paints correctly when loaded into the content area of 
the browser. Occurs on win32 and macos, but not on Linux.

As far as a black line in the mozilla banner, I don't see this on any platform,
but that would be a layout bug, not XPToolkit/Widgets.

Comment 3

18 years ago
assigning to evaughan for triage
Assignee: trudelle → evaughan

Comment 4

18 years ago
I see this on Mac too, in both the profile dialog, and the browser window, so 
it's XP.
Hardware: PC → All

Comment 5

18 years ago
updating summary for easier searching and adding self to cc: list

The background of the toolbar buttons does not paint all the way on initial 
launch but after collapsing and expanding the toolbar it looks good.

Comment 6

18 years ago
I'm pretty sure this is a problem with tiled image backgrounds; you see similar 
redraw problems on pages with such backgrounds, like http://www.coolight.com. 
Reassigning to dcone.
Assignee: evaughan → dcone

Comment 7

18 years ago
Note: I think another bug probably exists on the page background redraw issue, 
since I noticed eli looking at it yesterday.

Comment 8

18 years ago
whoops, forgot to update summary.
Summary: Initial drawing of browser window incorrect → toolbar background image not being painted / tiled fully
(Assignee)

Comment 9

18 years ago
This is a viewer2 problem.. I saw this with some of my other tests.
May be some sort of clipping thing.. 
Assignee: dcone → beard

Comment 10

18 years ago
Switching the pref to use the original view manager fixes the toolbar drawing 
problem, but does not affect the drawing of the page background on 
www.coolight.com.

Comment 11

18 years ago
*** Bug 34436 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
Don, would you look at this?
Assignee: beard → dcone

Updated

18 years ago
Target Milestone: --- → M17
(Assignee)

Comment 13

18 years ago
This was some sort of update problem.. but seems to be working now.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 14

18 years ago
verified using 2000071720 nightly build on w2k. The toolbar, profile manager, & 
website images load fine
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.