applet is initialized and reinitialized multiple times when frames' sizes are adjusted

RESOLVED DUPLICATE of bug 90268

Status

()

Core
Plug-ins
--
major
RESOLVED DUPLICATE of bug 90268
12 years ago
8 years ago

People

(Reporter: Pawel Zieminski, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

This can be reproduced using the attached sample (as soon as I figure out how to attach it).

Reproducible: Always

Steps to Reproduce:
1. Unzip the attached sample into a directory 
2. Open start.html in the browser. Open java console and turn on tracing to be able to monitor applet events (trace level 3 is fine)
3. Click on the link 'click here to start'

Actual Results:  
Note the multiple instance of the applet are created. Clicking the 'resize' button on the page with the embedded applet cause the applet to be reinitialized, and multiple applet instance to be created as well. Sometimes, after a few resizes of the frames the applet fails to initialize at all.

Expected Results:  
Single applet instance is initialized upon loading of test.html, and frame resizes do not cause the applet to get reinitialized. This used to work in Firefox 1.0, and works correctly in Mozilla 1.7.13.

This is reproducible on Firefox 1.5.0.4 on Windows 2003 Server, Fedora Core 5, Mac OS X 10.3.9.
(Reporter)

Comment 1

12 years ago
Created attachment 224504 [details]
here is the code sample to reproduce the problem
(Reporter)

Comment 2

12 years ago
Forgot to add that this is also reproducible with that latest build
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a1) Gecko/20060605 Minefield/3.0a1
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → Trunk
(Reporter)

Comment 3

12 years ago
This has something to do with changing the 'scrolling' attribute on each child frame. Commenting out line 106 in myscript.js (in the sample attached) fixes the behavior.
bz, does changing the scrolling attribute cause a reframe?
(Reporter)

Comment 5

12 years ago
It seems only when it's changed while changing widths of frames triggers this. Changing this attribute alone works fine.
Yes, since it's mapped to the CSS "overflow" properties.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 90268
You need to log in before you can comment on or make changes to this bug.