windows native theme broken (with classic theme)

RESOLVED FIXED

Status

()

Core
Graphics
--
blocker
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: mcsmurf, Assigned: vlad)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
To reproduce:
1. Download todays FF or SeaMonkey nightly
2. Start up
3. Look at various sites, open tabs, etc.

You'll for example notices these issues:
When hovering over a textbox/textarea, the border of the textarea will disappear.
When opening a new tab, the urlbar moves to where the tabbar is and the place where the urlbar should be gets a gray background color.
No vertical scrollbar on websites which require one.
Text on HTML form buttons appears in the wrong place, buttons are cut off, etc.
etc.

This worked fine in yesterdays nightly, so probably Bug 340452 causes this bug here and all the problems connected to it.
This appears to be a win2k-only problem, various people on XP have no problem at all
(In reply to comment #1)
> This appears to be a win2k-only problem, various people on XP have no problem
> at all

It's wrong. I can reproduce on WinXP with classic theme.
I think that the cause is that the |SetViewportOrgEx| was changed the position in |nsNativeThemeWin::DrawWidgetBackground| by bug 340452. But I cannot test it until return to my home...
Hmm, I must have forgotten to check something in.. looking
*** Bug 340484 has been marked as a duplicate of this bug. ***
I can't reproduce locally; updating my tree and grabbing the latest nightly to test.
Summary: GFX is broken (disappearing text areas, moving XUL elements, no scrollbars, disappearing colors, etc.) → windows native theme broken
Ok, reproduced with classic theme.  Ugh.
Summary: windows native theme broken → windows native theme broken (with classic theme)
Created attachment 224587 [details] [diff] [review]
fix classic themes

Forgot to make the "-" -> "+" change for the classic case.  (This duplicated code needs to be refactored.)
Assignee: nobody → vladimir
Status: NEW → ASSIGNED
Attachment #224587 - Flags: review?(pavlov)

Updated

12 years ago
Attachment #224587 - Flags: review?(pavlov) → review+
Checked in; sorry for the breakage!
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
thanks for the quick fix
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060606 Minefield/3.0a1 ID:2006060613 [cairo]

verified fixed on win2k/classic

Comment 12

12 years ago
*** Bug 340678 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.