Closed Bug 340519 Opened 16 years ago Closed 9 years ago

Use Mozilla as a Power-Point-like/OOo Impress-like Presentation Viewer

Categories

(Core :: General, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 120398

People

(Reporter: discoleo, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.12) Gecko/20050915
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.12) Gecko/20050915

There is a great potential to use Firefox (or SeaMonkey) as a Viewr for Power Point-like/OOo Impress-like presentations over the web.

It would be very useful to have a feature 'fullscreen' like in these presentation programs (i.e. real fullscreen; escape - for returning to window).

On the longer term: develop a filter to view such presentations directly into mozilla (see WeAPrez README).

WHY MOZILLA:
I have seen recently a number of presentations saved as graphics and put on the
web. Why save as a rigid picture and why loose all the functionality of the web?
The web is a dynamic medium, and non of the clasic programs recognizes this.

I have written a simple php-script that generates power-point-like web pages. I have also filed a feature request at OpenOfice.org (Issue 66169: http://www.openoffice.org/issues/show_bug.cgi?id=66169).

FURHTER DETAILS
There are some strong limitations of classical presentation programs (like
OpenOffice Impress and MS Power-Point):
 * need for proprietary program to view presentation
 * NO WEB pages (OOo)/ proprietary HTML (Power Point)
 * rigid layout: designed exclusively for a fixed screen size, while monitors
and browser sizes vary widely => for a web presentation)
 * primary concern with layout over content
 * NO multiple language support (for 2 languages you write virtually 2
presentations)
 * lack of functionality - NOT comparable to web possibilities

Therefore I think, mozilla can really offer an alternative to the classical presentation-programs.

I have opened a new project on sourceforge.net (WebAPrez, still in review phase,
therefore I append here the php-script). It is best viewed with Mozilla.

If you think, you can help, feel free to contact me. I am looking for many
program developers. This pre-alpha release is fully functional, but needs a
rewrite from ground up. I also hope, that developers at mozilla and at OOo recognize the potential of a web-presentation.


Kind regards

discoleo



Reproducible: Always

Steps to Reproduce:
1. feature request - view real fullscreen
2.
3.

Actual Results:  
A bar is still present at the top of the screen.
NO power-point like functionality (e.g. prev/next 'slide')

Expected Results:  
View power-point-like presentaions in Mozilla and have the viewing functionality of a professional presentation program (real fullscreen, previous/next,...)
This php-script generates power point-like presentations for the web. It should emphasize some of the possibilities of mozilla and the need to implement this presentation-program features.
Reporter, this is basically bug 120398 (support for projection media-type, like Opera) :

<style type="text/css" media="projection">
...
</style>

See also Eric Meyers work at http://www.meyerweb.com/eric/tools/s5/
Is there a web standard for presentations? "designed exclusively for a fixed screen size": What is the problem with, when you can zoom in and out of the browser window?  What do you mean by "primary concern with layout over content"? How do you propose to support multiple languages?  What are the "web possibilities" that you are thinking of?
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
Whiteboard: [CLOSEME 2010-11-01]
Since HTML 5, there are now plenty of ways to create online presentations. (See Google Docs), therefore, I am marking this as resolved. If anyone objects, then fine, but I do not believe this is important.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → REOPENED
Ever confirmed: true
Product: Firefox → Core
Resolution: WONTFIX → ---
Ms2ger: did you really intend to reopen this? If so, why? I'd basically agree with comment 5.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 120398
You need to log in before you can comment on or make changes to this bug.