Changing products should not give listboxes for items with only one choice

RESOLVED DUPLICATE of bug 204739

Status

()

RESOLVED DUPLICATE of bug 204739
13 years ago
13 years ago

People

(Reporter: timeless, Unassigned)

Tracking

2.20
x86
Windows XP

Details

(Reporter)

Description

13 years ago
steps:
1. create two products with distinct names (<g>)
2. create one component for each product with distinct names
3. create one version for each product with distinct names
4. define target milestone urls for both products
5. create one bug in one product
6. try to change the bug to the other product

expected actual results (tested on a hacked bugzilla)

Verify New Product Details...
Verify Version, Component, Target Milestone

You are moving the bug(s) to the product <blah>, and the version, component, and/or target milestone fields are no longer correct. Please set the correct version, component and target milestone now:

Version:    Component:  Target Milestone:
[1     |v]  [2     |v]  [3     |v]
|______|_|  |______|_|  |______|_|

[ Commit ]

Expected results:

Verify New Product Details...
Verify Version, Component, Target Milestone

You are moving the bug(s) to the product <blah>, and the version, component, and/or target milestone fields are no longer correct. Please set the correct version, component and target milestone now:

Version:    Component:  Target Milestone:
1           2           3

Note that if some of these have choices, only those should appear in listboxes, and the others should be static as shown in the expected results.

Other bugs of note (which I believe are filed, but qa should verify that when reading or verifying this bug): the component and target milestone headings should be links.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 204739 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.