Last Comment Bug 340668 - New ATK: Expose <label> as ATK_ROLE_LABEL, if available
: New ATK: Expose <label> as ATK_ROLE_LABEL, if available
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Aaron Leventhal
:
: alexander :surkov
Mentors:
Depends on: 340829
Blocks: newatk
  Show dependency treegraph
 
Reported: 2006-06-07 06:35 PDT by Aaron Leventhal
Modified: 2006-06-21 06:33 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Aaron Leventhal 2006-06-07 06:35:36 PDT
Any <label> or role="label" object should be exposed as ATK_ROLE_LABEL
Comment 1 Nian Liu(n/a in a long time) 2006-06-12 23:47:24 PDT
1.for xul and html label with createXUL/HTMLLabelAccessible
2.in nsAccessibilityService, add new create function
3.under src/atk/, add related nsXUL/HTMLLabelAccessibleWrap.h & .cpp
4.implement GetRole in .cpp

Aaron, 

Is that the right way?
Comment 2 Aaron Leventhal 2006-06-13 06:52:59 PDT
> Is that the right way?

I'm not sure yet. I want to fix bug 340829 first because a lot depends on that.

Comment 3 Nian Liu(n/a in a long time) 2006-06-13 20:21:34 PDT
(In reply to comment #2)
> > Is that the right way?
> 
> I'm not sure yet. I want to fix bug 340829 first because a lot depends on that.
> 

aaron,

then can you make a priority/dep picture for all new-atk bugs?

Note You need to log in before you can comment on or make changes to this bug.