Loading Hush Encryption Engine causes exception

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: Chris.Gundersen+mozilla, Assigned: yuanyi21)

Tracking

({crash})

1.8 Branch
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

When trying to log in to my free Hushmail account, the browser crashes when trying to load the Hush Encryption Engine. The browser locks up when trying to load the engine, and when I try to close the browser it generates the following error (Windows dialog):

XPCOM:EventReceiver: firefox.exe - Application Error
The instruction at "0x0809de05" referenced memory at "0x0000001d". The memory could not be "read".

Click on OK to terminate the program.
Click on CANCEL to debug the program.

Reproducible: Always

Steps to Reproduce:
1. Browse to https://www.hushmail.com/. Either:
 A. Enter your email address in the "Enter your full email address:" textbox or
 B. Use the shortcut URL https://www.hushmail.com/?hush_username=foo@hush.com
2. Click the "Sign In" button.
3. After the automatic redirect, click the link at the top of the page that reads "Click here if you would like continue with a free account".
4. As the Hush Encryption Engine loads, the browser will become unresponsive and will generate an error when closed.

Actual Results:  
The browser locked up and generated an error. All instances of FireFox were closed.

Expected Results:  
The Hush Encryption Engine would load, allowing me to enter the passphrase for my account and access my email.

about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-official-branding --enable-svg --enable-canvas --enable-update-packaging
(Reporter)

Comment 1

13 years ago
Created attachment 224692 [details]
Screenshot of the Hush Encryption Engine loader page

This is a screenshot of the page shown when the Hush Encryption engine is loading.
(Reporter)

Comment 2

13 years ago
Created attachment 224693 [details]
Screenshot of the error generated and the Feedback Agent

This is a screenshot of the error dialog generated when the browser is closed after locking up due to the Hush Encryption Engine loading, and the Feedback Agent that launches to submit the problem.

Comment 3

13 years ago
ok. 3 out of your 5 crashes are obviously in java.

Incident ID: 19414160
Stack Signature	jvm.dll + 0x9de05 (0x0809de05) 574e1bc0
Product ID	Firefox15
Build ID	2006042618
Trigger Time	2006-06-02 06:17:31.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	jvm.dll + (0009de05)
URL visited	https://mailserver8.hushmail.com
User Comments	
Since Last Crash	23778 sec
Total Uptime	620025 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
jvm.dll + 0x9de05 (0x0809de05)
jvm.dll + 0x9dcb7 (0x0809dcb7)
jvm.dll + 0x74aa1 (0x08074aa1)
jvm.dll + 0x7484f (0x0807484f)
jvm.dll + 0x7580b (0x0807580b)
jpinsp.dll + 0x5c15 (0x6d365c15)
jpinsp.dll + 0x1bb2 (0x6d361bb2)
nsHTMLAppletElementSH::GetPluginJSObject  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/dom/src/base/nsDOMClassInfo.cpp, line 8705]
nsHTMLExternalObjSH::PostCreate  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/dom/src/base/nsDOMClassInfo.cpp, line 8447]
nsObjectFrame::NotifyContentObjectWrapper  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsObjectFrame.cpp, line 2181]
nsObjectFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsObjectFrame.cpp, line 1267]
nsLineLayout::ReflowFrame  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsLineLayout.cpp, line 996]
nsBlockFrame::ReflowInlineFrame  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 4200]
nsBlockFrame::DoReflowInlineFrames  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 3853]
nsBlockFrame::ReflowInlineFrames  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 3735]
nsBlockFrame::ReflowLine  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 2729]
nsBlockFrame::ReflowDirtyLines  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 2263]
nsBlockFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 904]
nsBlockReflowContext::ReflowBlock  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockReflowContext.cpp, line 606]
nsBlockFrame::ReflowBlockFrame  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 3449]
nsBlockFrame::ReflowLine  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 2610]
nsBlockFrame::ReflowDirtyLines  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 2263]
nsBlockFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 904]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 905]
CanvasFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsHTMLFrame.cpp, line 536]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 905]
nsHTMLScrollFrame::ReflowScrolledFrame  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsGfxScrollFrame.cpp, line 523]
nsHTMLScrollFrame::ReflowContents  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsGfxScrollFrame.cpp, line 571]
nsHTMLScrollFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsGfxScrollFrame.cpp, line 769]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 905]
ViewportFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsViewportFrame.cpp, line 240]
IncrementalReflow::Dispatch  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp, line 914]
PresShell::ProcessReflowCommands  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp, line 6877]
ReflowEvent::HandleEvent  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp, line 6703]
PL_HandleEvent  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/xpcom/threads/plevent.c, line 689]
shdocvw.dll + 0x150c24 (0x778b0c24)
nsHTMLFormElement::DoSubmit  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/content/html/content/src/nsHTMLFormElement.cpp, line 806]
0x45d90824

the 2 that aren't look like this:

Incident ID: 19101121
Stack Signature	0x05db2fc8 c8ef5dba
Product ID	Firefox15
Build ID	2006042618
Trigger Time	2006-05-25 05:34:12.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	
URL visited	https://mailserver7.hushmail.com
User Comments	Trying to log into my hushmail account
Since Last Crash	83940 sec
Total Uptime	474590 sec
Trigger Reason	Privileged instruction
Source File, Line No.	N/A
Stack Trace 	
0x05db2fc8
nsBlockFrame::ReflowInlineFrame  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 4200]
nsBlockFrame::DoReflowInlineFrames  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 3853]
nsBlockFrame::ReflowInlineFrames  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 3735]
nsBlockFrame::ReflowLine  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 2729]
nsBlockFrame::ReflowDirtyLines  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 2263]
nsBlockFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 904]
nsBlockReflowContext::ReflowBlock  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockReflowContext.cpp, line 606]
nsBlockFrame::ReflowBlockFrame  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 3449]
nsBlockFrame::ReflowLine  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 2610]
nsBlockFrame::ReflowDirtyLines  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 2263]
nsBlockFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 904]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 905]
CanvasFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsHTMLFrame.cpp, line 536]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 905]
nsHTMLScrollFrame::ReflowScrolledFrame  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsGfxScrollFrame.cpp, line 523]
nsHTMLScrollFrame::ReflowContents  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsGfxScrollFrame.cpp, line 571]
nsHTMLScrollFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsGfxScrollFrame.cpp, line 769]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 905]
ViewportFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsViewportFrame.cpp, line 240]
IncrementalReflow::Dispatch  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp, line 914]
PresShell::ProcessReflowCommands  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp, line 6877]
ReflowEvent::HandleEvent  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp, line 6703]
PL_HandleEvent  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/xpcom/threads/plevent.c, line 689]
0x778b0c24
nsHTMLFormElement::DoSubmit  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/content/html/content/src/nsHTMLFormElement.cpp, line 806]
0x45d90824

please visit about:plugins and find out what version of java you're using...
Assignee: nobody → yuanyi21
Severity: normal → critical
Component: General → Java: OJI
Keywords: crash
Product: Firefox → Core
QA Contact: general → zhayupeng
Version: unspecified → 1.8 Branch
(Reporter)

Comment 4

13 years ago
Created attachment 224719 [details]
JPG Screenshot of about:plugins (Part 1 of 1)

JPG Screenshot of about:plugins (Part 1 of 1)
(Reporter)

Comment 5

13 years ago
Created attachment 224720 [details]
JPG Screenshot of about:plugins (Part 1 of 2)

JPG Screenshot of about:plugins (Part 1 of 2)
Attachment #224719 - Attachment is obsolete: true
(Reporter)

Comment 6

13 years ago
Created attachment 224721 [details]
JPG Screenshot of about:plugins (Part 2 of 2)

JPG Screenshot of about:plugins (Part 2 of 2)
(Reporter)

Comment 7

13 years ago
I've attached screenshots of the output of about:plugins - the particulars about the Java Plug-ins are below:

Java Plug-in

    File name: NPJava11.dll
    Java Plug-in 1.4.2_04 for Netscape Navigator (DLL Helper)

    File name: NPJava12.dll
    Java Plug-in 1.4.2_04 for Netscape Navigator (DLL Helper)

    File name: NPJava13.dll
    Java Plug-in 1.4.2_04 for Netscape Navigator (DLL Helper)

    File name: NPJava14.dll
    Java Plug-in 1.4.2_04 for Netscape Navigator (DLL Helper)

    File name: NPJava32.dll
    Java Plug-in 1.4.2_04 for Netscape Navigator (DLL Helper)

    File name: NPJPI142_04.dll
    Java Plug-in 1.4.2_04 for Netscape Navigator (DLL Helper)

    File name: NPOJI610.dll
    Java Plug-in 1.4.2_04 for Netscape Navigator (DLL Helper)
(Reporter)

Comment 8

13 years ago
Created attachment 224726 [details]
Screenshot from Java software verifier

Screenshot from Java software verifier
(Reporter)

Comment 9

13 years ago
I just updated the JRE to "J2SE(TM) Runtime Environment 5.0 Update 7" and confirmed that my version is at 1.5.0_07. I just tried logging into hushmail twice and it has worked both times. I suspect that my Java version wasn't as recent as I thought.
Indeed, your JRE was a bit old. Now that it works with the current JRE-->wfm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.