If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Download Manager's option to take file opening action is greyed out; MUST download to disk

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: George Kinal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-15])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

In Windows versions of FF and Mozilla, if file types (PDFs, DOCs, MP3s)are designated for direct opening by a plug-in or application, that action is taken, and can be made consistent.

In Firefox 1.5 under Linux, the option of direct opening is greyed out and unavailable.

In Mozilla 1.7 under Linux, by the way, that option is available but the choice is not sticky (take this action each time button is greyed out) -  this is better than not being able to open at all, but still a pain.

Reproducible: Always

Steps to Reproduce:
1. Go to any site (e.g. IRS) offering PDF files
2. Choose (click on) such a link.
3. See that the only option available in FF is to download, then later manually open the PDF file separately, or, in Mozilla, note that the "open with" option IS available BUT this option cannot be set to be default mode.
Component: Download Manager → File Handling
QA Contact: download.manager → file.handling
Dupe of/related to bug 264492?
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> Dupe of/related to bug 264492?
> 
This may be a dupe of 264492 in the Firefox case, and it is certainly related to it. But this does not explain the behavior under Mozilla. The Mozilla behavior is closer to what's needed, because at least the "open with" option IS available. BUT I would prefer that the open-with option become the default option (and/or, be "sticky" - remain the default once that option is chosen in lieu of the save-to-folder option).

GK
This bug was reported using Firefox 3.0 or older, which is no longer supported. The bug has also not been changed in over 500 days and is still in UNCO.
Reporter, please retest this bug in Firefox 3.6.10 or later using a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles. If you still see this problem, please update the bug. If you no longer see the bug, please set the resolution to RESOLVED, WORKSFORME.

This is a mass search of unconfirmed bugs that have no activity on them, so if you feel a bug was marked in error, just remove the CLOSEME comment in the whiteboard within the next month.
Whiteboard: [CLOSEME 2010-11-15]
No reply, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

7 years ago
This is an ANCIENT bug. Does not exist in current (since 2008 at least) versions of Firefox.
Resolution: INCOMPLETE → FIXED

Updated

7 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.