ASP.NET Atlas auto-postback CheckBox/RadioButton label crashes Firefox 1.5.0.4

VERIFIED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
VERIFIED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Brian Lalonde, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Firefox 1.5.0.4 (on Windows) crashes when clicking a label for an auto-postback checkbox or radiobutton created with ASP.NET Atlas 2.0.50727.60406.

This does not happen with Firefox 1.5.0.3 or earlier, any Mac Firefox, Netscape 8, Seamonkey, or K-Meleon.

Reproducible: Always

Steps to Reproduce:
1. Create an ASP.NET Atlas web application.
2. Add the following code to the .aspx page:

  <atlas:ScriptManager ID="mgr" runat="server" EnablePartialRendering="true" />
  <atlas:UpdatePanel ID="update" runat="server">
  <ContentTemplate>
  <asp:CheckBox ID="CheckBox1" AutoPostBack="true" Text="Click this text"
    runat="server"  OnCheckedChanged="CheckBox1_CheckedChanged1" /><br />
  <asp:Label ID="Label1" runat="server" />
  </ContentTemplate>
  </atlas:UpdatePanel>

3. Add the following code to the .aspx.cs code-behind page:

  protected void CheckBox1_CheckedChanged1(object sender, EventArgs e)
  {
    Label1.Text = (CheckBox1.Checked) ? "checked" : "unchecked"; ;
  }

4. Visit the app in Firefox 1.5.0.4.
5. Click the checkbox to toggle the text.
6. Click the checkbox label to crash the browser.

Actual Results:  
Browser crashes.

Expected Results:  
Browser should not crash.

Copious client script is generated by Atlas.

It's best to use the Web Dev Toolbar to view the given URL's script.
(Reporter)

Comment 1

12 years ago
Created attachment 224759 [details]
The client HTML generated by ASP.NET Atlas

This is the HTML send to the browser.
(Reporter)

Comment 2

12 years ago
Created attachment 224760 [details]
The client script generated by ASP.NET Atlas (zipped)

The concatenated JavaScript sent to the browser.
(Reporter)

Updated

12 years ago
Attachment #224760 - Attachment description: The client script generated by ASP.NET Atlas → The client script generated by ASP.NET Atlas (zipped)

Comment 3

12 years ago
Yep, definitely happens. (In case anyone else was unclear you can reproduce just by clicking on the URL in the post, then clicking the checkbox.)
Crashes me with the not very useful looking TB19805583H in Firefox 1.5.0.4, but doesn't crash either 2.0a3 or trunk, so apparently it's fixed... somewhere.
Component: General → General
Keywords: crash
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → 1.8 Branch

Comment 5

12 years ago
well, all i can see is garbage collection, although someone could blame xpconnect (as long as they're willing to fix it ;-).
Assignee: nobody → general
Component: General → JavaScript Engine
QA Contact: general → general

Comment 6

12 years ago
(In reply to comment #3)
> Yep, definitely happens. (In case anyone else was unclear you can reproduce
> just by clicking on the URL in the post, then clicking the checkbox.)

The testcase works for me. The browser does not crash when I click the checkbox, I get page not found. Using ff1.5.0.4 on win2k 

Comment 7

12 years ago
Did you click on the attachment or the URL link?  The attachment (which is just that) gives a 404, but if you click on the URL (http://webcoder.info/test/FxCbTest/) and click on the text of the checkbox (not the checkbox, that works) it should crash.  It crashes mine; 1.5.0.4 on XPsp2.

Comment 8

12 years ago
I don't crash with today's 20060616 1.5.0.5 build. Please reopen if you can reproduce with a build from <http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8.0/>
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 9

12 years ago
I just noticed this in the window where I kicked off firefox...

$ ./firefox -P Debug "http://webcoder.info/test/FxCbTest/"
An error occurred updating the cmd_copy command
(Reporter)

Comment 10

12 years ago
It seems like that dev version no longer crashes, but it doesn't work either.

The text below never toggles with the state of the checkbox:

Error: [Exception... "Access to restricted URI denied"  code: "1012" nsresult: "0x805303f4 (NS_ERROR_DOM_BAD_URI)"  location: "http://webcoder.info/test/FxCbTest/WebResource.axd?d=iGuH...BG24E1&t=632852857166411562 Line: 11349"]
Source File: http://webcoder.info/test/FxCbTest/WebResource.axd?d=iGuH...BG24E1&t=632852857166411562
Line: 11349

Restricted URI? That looks legit to me.

Comment 11

12 years ago
This Error occurs every time, only when the user clicks on the label portion of the checkbox or radio button.  

Here is a forum that describes many people having this problem:
http://forums.asp.net/thread/1322578.aspx

Comment 12

12 years ago
(In reply to comment #11)
> This Error occurs every time, only when the user clicks on the label portion of
> the checkbox or radio button.  
> 
> Here is a forum that describes many people having this problem:
> http://forums.asp.net/thread/1322578.aspx
> 

Ok, I can confirm a crash in Firefox 1.5.0.4, but not in Firefox 1.5.0.5, Firefox 2b1 or Minefield on Windows XP. Firefox 1.5.0.5 will be released shortly and users of 1.5.0.4 will be quickly updated, so this shouldn't be a problem soon.
(Reporter)

Comment 13

12 years ago
Yes, it's great that .5 no longer crashes, but the fact that it no longer works isn't terribly satisfying.

Comment 14

12 years ago
(In reply to comment #13)
> Yes, it's great that .5 no longer crashes, but the fact that it no longer works
> isn't terribly satisfying.
> 

http://webcoder.info/test/FxCbTest/ works for me in 1.5.0.5/winxp.

Comment 15

12 years ago
(In reply to comment #14)

I did notice the following after clicking the label twice and closing 1505 though (not reproducible with 2.0 or 3.0).

$ /Programs/mozilla.org/firefox-1.5.0.5.en-US.win32/firefox/firefox.exe -P Debug "http://webcoder.info/test/FxCbTest/"
An error occurred updating the cmd_copy command
An error occurred updating the cmd_copy command



(In reply to comment #13)
> Yes, it's great that .5 no longer crashes, but the fact that it no longer works
> isn't terribly satisfying.

1.5.0.5 "works" for me, I get the exact same behavior as 1.5.0.3 (and confirm the 1.5.0.4 crash). Maybe bclary and I are not understanding the testcase? Or maybe you tried an earlier incarnation of 1.5.0.5?

The bug claims to be filed against windows which is what Bob and I tested on. Are you using Linux or Mac instead? Could you try again with the 1.5.0.5 rc4 build?

Anyway, the crash is fixed.

(Reporter)

Comment 17

12 years ago
Confirmed: fixed. Yay! w00t!

(My bad. I hadn't tried a recent enough nightly build.)

Not only doesn't it crash, but it works again, too!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.