Collected Address Book - Sync to palm "Unfiled Category"

RESOLVED WONTFIX

Status

MailNews Core Graveyard
Palm Sync
--
enhancement
RESOLVED WONTFIX
12 years ago
9 years ago

People

(Reporter: Don, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows XP

Details

(Whiteboard: workaround comment 10)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

When I send a message to an address that's not already in my address book, that address ends up in the "Collected Addresses" address book.  I don't like this "feature" but that's for the TBird people.

I'd like to see two settigns:

1) user specify Palm Category to be sync'd with the "Collected Addresses" address book.
2) user specify whether or not "Collected Addresses" is even sync'd with the Palm.

Reproducible: Couldn't Reproduce

Actual Results:  
Personal Address Book is empty.

Comment 1

12 years ago
Mark, is it correct that TB's direction is THE "collected address book" is being phased out - reference http://wiki.mozilla.org/User_talk:Standard8#Collected_Address_Book_Removal.3F
(In reply to comment #0)
> When I send a message to an address that's not already in my address book, that
> address ends up in the "Collected Addresses" address book.  I don't like this
> "feature" but that's for the TBird people.

Emm, you can switch that feature off in your preferences.

(In reply to comment #1)
> Mark, is it correct that TB's direction is THE "collected address book" is
> being phased out - reference
> http://wiki.mozilla.org/User_talk:Standard8#Collected_Address_Book_Removal.3F

That's unclear at the moment. The last discussion I knew of suggested we might be keeping it.

Comment 3

12 years ago
(In reply to comment #0)
> 1) user specify Palm Category to be sync'd with the "Collected Addresses"
> address book.

at tools>options>composition>addressing - last item on addressing tab


> 2) user specify whether or not "Collected Addresses" is even sync'd with the
> Palm.

you want disablePalmSync described in bug 261405 comment 20 


Does this address both of your issues?

Comment 4

12 years ago
correction

(In reply to comment #0)
> When I send a message to an address that's not already in my address book, that
> address ends up in the "Collected Addresses" address book.  I don't like this
> "feature" but that's for the TBird people.

at tools>options>composition>addressing - last item on addressing tab
 

> 1) user specify Palm Category to be sync'd with the "Collected Addresses"
> address book.

This won't happen. The analogy of "Personal Address Book" mapped to Personal on the palm is not user controled and there is no plans to provide user specified mapping.
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> This won't happen. The analogy of "Personal Address Book" mapped to Personal on
> the palm is not user controled and there is no plans to provide user specified
> mapping.
I wasn't so much interested in changing the mapping for Personal Address Book.  I was more concerned with Collected Addresses.  

Now that I know how to turn it off, that's good.  But if it's going to be on, I'd prefer that Collected Addresses be mapped to Unfiled on the Palm.  I think it would make more sense.  That's really the main purpose of "Unfiled" on the Palm as far as I know.  And with such a change, a category wouldn't be taken by Collected Addresses--the Palm can only handle 15 categories.

Thanks for the heads up on DisablePalmSync.

Comment 6

11 years ago
Don, as much as the idea makes some sense, I have a some problems with equating collected to unfiled and am inclined to suggest WONTFIX. I think bug 171125 is what would really more directly address your concerns.  To address some aspects of this ...

"Collected" in TB is fraught with issues, 1) it's on by default 2) the folder name can be variable in TB options, and 3) in the future it probably won't be required/won't exist for some users - as there are people who don't use it and don't want it (bug 171125).  

Conversely, unfiled on the palm won't change (in the foreseeable future)/required (by palm), the entries are (relatively) avoidable - and also I can't think of a reasonable mapping to an address book name that anyone might normally keep on a PC.

What do you think?
Summary: Collected Addresses - Sync to "Unfiled Category", Even option to NOT sync certain categories to Palm → Collected Address Book - Sync to palm "Unfiled Category"

Comment 7

11 years ago
One other aspect - for those that really want/use/need/desire/love collected address book and also sync, I can't imagine they'd want to map it to unfiled. This thought is pushing me closer to wontfix.

I almost forgot to mention - a great project for someone is to create an extension for PalmSync with some UI options - for example expose "disablePalmSync".

PalmSyncUI anyone?
(Reporter)

Comment 8

11 years ago
<<also I can't think of a reasonable mapping to an address book name that anyone might normally keep on a PC.

What do you think?>>
What is the purpose of 'Collected Addresses'?  My understanding is that it's for addresses to which I've sent messages, but haven't filed them--right?

That's pretty much the same purpose for 'Unfiled' on the Palm.  What's more reasonable than to map them to each other?

<<I can't imagine they'd want to map it to unfiled.>>
This thought has me baffled.  Why not allow the user to decide what category and if it's 'Unfiled', so be it?

I've turned on DisablePalmSync, so it no longer effects me.  I only offer these comments to help improve the software.

Comment 9

11 years ago
David, I'd like your take on this.  Gordon you commented to me about this in email a couple months ago, but these are additional considerations below.

Don's suggestion is worth considering. For example for some people it might help them avoid hitting the 15 address book limit.

But I am hesitant for these reasons:

1. complicates user choice
   someone who has CAB turned on for email might not want CAB synced to the palm
   (CAB may be large and user might not want it on their PDA)
2. potential for confusion 
   CAB==unfiled is not as obvious a mapping to users as PAB==personal 
3. CAB being a "special" AB
   if TB's use or manipulation of CAB changes in the future this may cause problems or complications
4. can't put my finger on it, but it seems it could open up a dataloss situation - not all PDAs (and users) are created equal

What do you think?

Comment 10

11 years ago
Don, thanks for the suggestion. I have decided to close this. One of Gordon's comments sums up my thought "I am not sure that you would ever get universal agreement that the Palm's Unfiled category should be synced to TBird's Collected Addresses"

==> WONTFIX


partial workaround: to skip syncing the collected address book, define a preference of ldap_2.servers.history.disablePalmSync set to TRUE
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
Whiteboard: workaround comment 10

Comment 11

11 years ago
Thanks.  But I've since noticed that TB2.0 will allow me to specify which address book to use to store "collected" addresses.  I'm going to try setting that to "Unfiled" when I get home tonight.
Product: Core → MailNews Core

Updated

9 years ago
Component: Palm Sync → Palm Sync
Product: MailNews Core → MailNews Core Graveyard
You need to log in before you can comment on or make changes to this bug.