middle-click on form fields should paste not load as url

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Markus Tacker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.4) Gecko/20060607 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.4) Gecko/20060607 Firefox/1.5.0.4

I cannot paste text into a form element vie middle click any longer. Instead it tries to load the text as url.

This used to work in 1.5.0.3 and earlier.

middlemouse.contentLoadURL = true
middlemouse.paste = true

Reproducible: Always

Steps to Reproduce:
1. Highlight any text
2. Move mouse over form field
3. Click middle mouse button

Actual Results:  
Loads text as URL

Expected Results:  
Paste text into form field

Comment 1

11 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20061022 Minefield/3.0a1

I agree that the behaviour is wrong; but has it every been confirmed? Are you 
using any extensions?

This report is probably WFM.

Comment 2

10 years ago
WFM on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007112604 Minefield/3.0b2pre ID:2007112604

Since this bug report has not been confirmed in more than 12 months and has been reported for Firefox 1.5, I'm closing this now as WORKSFORME.

Please reopen this bug if you can reproduce the problem with a current Firefox release like Firefox 3.0 beta 1 or a nightly build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.