Form auto-complete items should have an UI to be deleted

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
13 years ago
10 years ago

People

(Reporter: NicolasWeb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

For 'normal' (no computer addict ...) people, the existing keyboard (shift + del) method to remove a from autocomplete entrie is not easy : they don't know that this is possible. They need something that show them that they can do it.


Reproducible: Always

Steps to Reproduce:
1.open a page with a web form
2.enter word with a error (mozila)
3.press Enter
4.Comme back to the page with a web form
5.Enter the begining (mozil) of the right word (mozilla)
6.Try to find how to delete the wrong item when you see your screen like that

Actual Results:  
You have to use the keyboard :
A. hightlight the item
B. press shift + del

Expected Results:  
Something that SHOW you can delete an entrie.
1.Maybe a close button for each item (gray for all and in color for the active item). See attachements
2. An item "Delete an entrie" that highlight in red the active item on mouse over. On click it remove the entrie but keep the entries box on screen. See attachements

The <a href="show_bug.cgi?id=338479" title="RESOLVED - Unable to delete auto complete entries">bug 338479</a> explain the problem and show the keyboard solution.
(Reporter)

Comment 1

13 years ago
Created attachment 224855 [details]
delete button solving suggestion
(Reporter)

Comment 2

13 years ago
Created attachment 224856 [details]
Red Item solving suggestion

Comment 3

13 years ago
Will it help that for Firefox 2 deleting autocomplete items will work the same as for IE (i.e. through hitting the Delete key only)?

The first solution has the issue that the delete buttons are too easy to hit when you're aiming for the scrollbar. And the second solution becomes quite cumbersome when you want the delete the first entry of a 20 item list (of which only the first half or so are visible).

I agree though that it would be nice if it were more obvious that single autocomplete items can be deleted (so as to avoid unnecessary data loss when somebody wants to get rid of one item and clears all private data for lack of a better alternative).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

13 years ago
Deleting an entry by hitting the Delete key only will be a more intuitive way, so I think it is better.
But I don't think that's the best solution because we must suggest and show to the user that he can delete entries. In addition, that's not 'normal' to have an action on a only highlighted element. It should be selected, or clicked. Do you agree ?

1. Maybe we need an auto-complete entries manager. But, I think it's not enough integrated solution, we need a smoother UI.
2. We can add an pop up menu "Delete this entry" for each item. However it's not enough visible and 'normal' make pop up something in front of something that is a pop up too.
3. We can improve the close buttun solution
   3.1 put the left buttun on the left side
   3.2 ask a confirmation to the user
4. We can improve the Red menu item solution by making it non-scrollable. In that case, we have to be careful about a possible issue with Enter keypress.

Maybe ther is a good way with a floating element ?

If you have better ideas, they are welcome.
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
This issue has come up before, in the context of the password manager. Not going to add kludgy autocomplete-menu UI for deleting entries here either.

This task is better left to extensions implementing a full-fledged Form History Data Management UI for people those who want ultimate control over form history.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.