Mail header of forwarded message is either corrupted or in English

VERIFIED FIXED in M17

Status

MailNews Core
Localization
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: ji, Assigned: rchen)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

18 years ago
Build: 032417c ja build.

When forwarding a message inline, the Japanese words for Subject, Date, To
and From in the header of the original message are corrupted. 
When forwarding a message as an attachment, those words are in English.

Steps of reproduce:
1. Launch Mail.
2. Highlight a mail and select Message | Forward |Inline,
   on the forward mail compose page, you'll see the corrupted ja words.
   After receiving, the header of the forwarded mail is corrupted in the msg
   view pane.
3. Highlight a mail and select Message | Forward |as Attachment,
   send the mail to the testing account itself. After receiving, you'll the
   header of the forwarded mail is in English.
(Assignee)

Comment 1

18 years ago
We have a workaround for Jab1.
Status: NEW → ASSIGNED
(Reporter)

Comment 2

18 years ago
The workaround is in ja 032417d build.

Comment 3

18 years ago
After tallking to mscott in detail (Thanks! Scott for taking 
the time to help us), I reverted the following strings 
in "chrome: messenger: locale: ja-JP: mime.properties" to 
English for JA Beta 1.

String IDs: 1000 - 1023

Comment 4

18 years ago
Contact to ji.
QA Contact: momoi → ji
(Assignee)

Updated

18 years ago
Target Milestone: --- → M16
(Assignee)

Comment 5

18 years ago
Kat, have you filed a bug for Scott? This bug has the dependency on the core 
bug. 

Comment 6

18 years ago
That's 34666 assigned to me.
(Assignee)

Comment 7

18 years ago
Add dependency on 34666.
Blocks: 34666
Target Milestone: M16 → M17

Updated

18 years ago
Keywords: nsbeta2
(Assignee)

Updated

18 years ago
No longer blocks: 34666
(Assignee)

Updated

18 years ago
Depends on: 34666

Comment 8

18 years ago
Putting on [nsbeta2+] radar for beta2 fix.
Whiteboard: [nsbeta2+]

Comment 9

18 years ago
34666 have been fixed since 4/27. What is the status of THIS bug now ?

Comment 10

18 years ago
rchen said since 34666 is fixed we should mark this bug fix so IQA can verify 
it. momoi- please verify this against jab2. Thanks

Comment 11

18 years ago
mark it fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

18 years ago
When forwarding a message inline, the header of the forwarded mail is in
Japanese and is not corrupted. However, when forwarding a message as attachment,
the header of the forwarded mail is in English. This bug is only partially
fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 13

18 years ago
Above test results are done with Japanese 2000-07-21-09 build.

Comment 14

18 years ago
I wouldn't hold beta2 for this, this late in the beta2 cycle. i.e. I would not
pull the beta off the wire for this problem.

If it really isn't fixed, then I think we need to remove the beta2+ label and
reschedule for beta3.

Comment 15

18 years ago
I suggest that we don't deal with the headers in attachments. 
Attachments should not be modified from what you received from
the sender and that includes RFC 822 headers in ASCII.
We forward msgs to different language users and we should
not lock in headers in one language. 
If the inline headers can show in Japanese, then we should
close this bug.

By the way, I filed a separate bug to revert all inline
headers from Japanese to English for JA build. Japanese users 
may forward inline msgs to non-Japanese users and may even use 
Western encoding. I don't think it is a good idea to keep 
quoted RFC 822 headers in Japanese. 
(Reporter)

Comment 16

18 years ago
That makes sense. Marked it as fixed.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 17

18 years ago
Marked it as verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.