Would like all frames to show their own URL bars

RESOLVED WONTFIX

Status

()

Core
Layout: HTML Frames
--
enhancement
RESOLVED WONTFIX
12 years ago
10 years ago

People

(Reporter: Jon Williams, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060404 SeaMonkey/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060404 SeaMonkey/1.0.1

Would be nice if you could set the "view" to require all frames to show the URL bar so that you can edit the URL and/or  edit the URL in the frame.   NOTE: IE7 will now require all popup windows have a URL bar and so this feature seems to be inline with what is fashionable.

Reproducible: Always
(Reporter)

Updated

12 years ago
Summary: Would like all frames to show a URL bar → Would like all frames to show their own URL bars

Comment 1

12 years ago
This wouldn't protect you from phishing (it might even mislead you, since address bars in the content area could be spoofed) and it would break all kinds of uses of iframes.  I vote for wontfix.

Comment 2

12 years ago
"NOTE: IE7 will now require all popup windows have a URL bar and so this feature seems to be inline with what is fashionable."

See Bug 337344

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 337344
Uh... This is nothing like bug 337344, sorry.  This bug isn't even about popup windows, necessarily, but all frames in general.  And bug 337344 is trying hard to not even have a URL bar on windows...
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to comment #1)
> This wouldn't protect you from phishing (it might even mislead you, since
> address bars in the content area could be spoofed) and it would break all kinds
> of uses of iframes.  I vote for wontfix.

So do I.
Component: Location Bar and Autocomplete → Layout: HTML Frames
OS: Windows XP → All
Product: Firefox → Core
QA Contact: location.bar → layout.html-frames
Hardware: PC → All
This would completely break the Web.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.