about:config preference being cleared when using profile on Windows after Linux

RESOLVED DUPLICATE of bug 326263

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 326263
12 years ago
12 years ago

People

(Reporter: Michael Elkevizth, Unassigned)

Tracking

1.5.0.x Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060605 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060605 Firefox/1.5.0.4

I currently use Firefox on a dual boot machine with Windows XP and Gentoo Linux. I am running version 1.5.0.4 on both and would like them to act uniformly when I use Firefox on either system. I have a FAT partition that both OS's look to a common profile on. The problem that I'm seeing is that in Windows when I click with the middle mouse button on a tab it closes, which is the default action in Windows, in Linux I have to change the “middlemouse.contentLoadURL” option to “false” in about:config in order to get the same action. Which to me means that somehow the config is not actually set in the profile or I should not have to set this, because it should have been “carried over” from my profile that was originally setup in Windows. But, they must not be totally separate from the profile, because as soon as I use the profile from Windows again, the next time after I use the profile in Linux the option has changed back to default and I no longer have uniform action between the two OS's. What is really odd to me is that when the option is changed to false in Linux it works in Linux until I use it in Windows and then use it in Linux again, but the action in Windows is not altered at all. Maybe the only way I can solve this is to compile Firefox on Linux with the same options as how it is compiled on Windows, but it seems like the preferences should really be profile specific (at least for things like this). If I do need to recompile, could someone point me in the right direction for how to do this.

Reproducible: Always

Steps to Reproduce:
1.Setup a profile that can be shared between Windows and Linux
2.Change the middlemouse.contentLoadURL value to false in about:config on the Linux OS
3.Use the profile from the Windows OS
4.Open about:config on the Linux OS and check the middlemouse.contentLoadURL option
Actual Results:  
The middlemouse.contentLoadURL option changed back to "default"

Expected Results:  
The middlemouse.contentLoadURL option should have stayed set to "false"
Whiteboard: DUPEME
Version: unspecified → 1.5.0.x Branch
Agreed.

*** This bug has been marked as a duplicate of 326263 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.