Closed Bug 34092 Opened 20 years ago Closed 20 years ago

installing PSM from iPlanet crash

Categories

(Core Graveyard :: Installer: XPInstall Engine, defect, P3, critical)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: dougt, Assigned: troy)

References

()

Details

(Keywords: smoketest)

__sbh_free_block(tagHeader * 0x00c41efc, void * 0x038afaf0) line 350 + 6 bytes
_realloc_base(void * 0x038afaf0, unsigned int 200) line 101 + 13 bytes
realloc_help(void * 0x038afb10, unsigned int 164, int 1, const char * 
0x00000000, int 0, int 1) line 636 + 16 bytes
_realloc_dbg(void * 0x038afb10, unsigned int 164, int 1, const char * 
0x00000000, int 0) line 806 + 27 bytes
realloc(void * 0x038afb10, unsigned int 164) line 755 + 19 bytes
JS_realloc(JSContext * 0x038764d0, void * 0x038afb10, unsigned int 164) line 
1027 + 14 bytes
js_AllocSlot(JSContext * 0x038764d0, JSObject * 0x02468d08, unsigned long * 
0x039afc9c) line 1505 + 20 bytes
js_NewScopeProperty(JSContext * 0x038764d0, JSScope * 0x038aede0, long 17096352, 
int (JSContext *, JSObject *, long, long *)* 0x002a1235 _JS_PropertyStub, int 
(JSContext *, JSObject *, long, long *)* 0x002a1235 _JS_PropertyStub, unsigned 
int 0) line 477 + 20 bytes
js_DefineProperty(JSContext * 0x038764d0, JSObject * 0x02468d08, long 17096352, 
long 38178248, int (JSContext *, JSObject *, long, long *)* 0x002a1235 
_JS_PropertyStub, int (JSContext *, JSObject *, long, long *)* 0x002a1235 
_JS_PropertyStub, unsigned int 0, JSProperty * * 0x00000000) line 1660 + 29 
bytes
js_DefineFunction(JSContext * 0x038764d0, JSObject * 0x02468d08, JSAtom * 
0x0104dea0, int (JSContext *, JSObject *, unsigned int, long *, long *)* 
0x002b58ac date_setUTCFullYear(JSContext *, JSObject *, unsigned int, long *, 
long *), unsigned int 3, unsigned int 0) line 1646 + 40 bytes
JS_DefineFunction(JSContext * 0x038764d0, JSObject * 0x02468d08, const char * 
0x00333514, int (JSContext *, JSObject *, unsigned int, long *, long *)* 
0x002b58ac date_setUTCFullYear(JSContext *, JSObject *, unsigned int, long *, 
long *), unsigned int 3, unsigned int 0) line 2256 + 29 bytes
JS_DefineFunctions(JSContext * 0x038764d0, JSObject * 0x02468d08, JSFunctionSpec 
* 0x003331d0) line 2238 + 44 bytes
JS_InitClass(JSContext * 0x038764d0, JSObject * 0x02467e68, JSObject * 
0x00000000, JSClass * 0x00332ef8 date_class, int (JSContext *, JSObject *, 
unsigned int, long *, long *)* 0x002b64ac Date(JSContext *, JSObject *, unsigned 
int, long *, long *), unsigned int 7, JSPropertySpec * 0x00000000, 
JSFunctionSpec * 0x003330c8 date_methods, JSPropertySpec * 0x00000000, ...) line 
1336 + 53
js_InitDateClass(JSContext * 0x038764d0, JSObject * 0x02467e68) line 1854 + 41 
bytes
JS_InitStandardClasses(JSContext * 0x038764d0, JSObject * 0x02467e68) line 997 + 
209 bytes
SetupInstallContext(nsIZipReader * 0x024e9930, const nsFileSpec & {...}, const 
unsigned short * 0x03862a40, const unsigned short * 0x10086dc8 
gCommonEmptyBuffer, JSRuntime * 0x00e810b0, JSContext * * 0x039aff08, JSObject * 
* 0x039aff0c) line 238 + 14 bytes
RunInstallOnThread(void * 0x03862fb0) line 369 + 50 bytes
_PR_NativeRunThread(void * 0x03865da0) line 399 + 13 bytes
_threadstartex(void * 0x03862c20) line 212 + 13 bytes
KERNEL32! 77f04ee8()
Severity: normal → blocker
Keywords: smoketest
Target Milestone: --- → M15
I had a build from this morning under Win2000.  I tried the path:
  http://docs.iplanet.com/docs/manuals/psm/psm-mozilla/index.html

and clicked on the "Install Netscape PSM for Windows" button.  I got a lot of 
assertions in mozilla/xpcom/base/nsDebug.cpp line 372, but everything installed 
fine.  No crash for me during the installation.

However, I did get a crash when exiting netscp6.exe right afterwards:

js_RemoveRoot(JSRuntime * 0xdddddddd, void * 0x03a7f6b4) line 178 + 3 bytes
JS_RemoveRoot(JSContext * 0x03469570, void * 0x03a7f6b4) line 1081 + 16 bytes
nsXPITriggerInfo::~nsXPITriggerInfo() line 102 + 20 bytes
nsXPITriggerInfo::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsXPInstallManager::~nsXPInstallManager() line 98 + 31 bytes
nsXPInstallManager::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsXPInstallManager::Release(nsXPInstallManager * const 0x03a7f110) line 103 + 
129 bytes
nsXPCWrappedNative::~nsXPCWrappedNative() line 390 + 27 bytes
nsXPCWrappedNative::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsXPCWrappedNative::Release(nsXPCWrappedNative * const 0x040ac2b0) line 71 + 31 
bytes
nsXPCWrappedNative::JSObjectFinalized(JSContext * 0x0274fc30, JSObject * 
0x02927b98) line 96
WrappedNative_Finalize(JSContext * 0x0274fc30, JSObject * 0x02927b98) line 691
js_FinalizeObject(JSContext * 0x0274fc30, JSObject * 0x02927b98) line 1470 + 114 
bytes
js_GC(JSContext * 0x0274fc30) line 898 + 11 bytes
js_ForceGC(JSContext * 0x0274fc30) line 678 + 9 bytes
js_DestroyContext(JSContext * 0x0274fc30, int 2) line 183 + 9 bytes
JS_DestroyContext(JSContext * 0x0274fc30) line 794 + 11 bytes
nsJSContext::~nsJSContext() line 186 + 13 bytes
nsJSContext::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsJSContext::Release(nsJSContext * const 0x0274fdc0) line 195 + 154 bytes
nsCOMPtr<nsIScriptContext>::assign_assuming_AddRef(nsIScriptContext * 
0x00000000) line 447
nsCOMPtr<nsIScriptContext>::assign_with_AddRef(nsISupports * 0x00000000) line 
818
nsCOMPtr<nsIScriptContext>::operator=(nsIScriptContext * 0x00000000) line 557
nsDocShell::Destroy(nsDocShell * const 0x0175f0c4) line 1281
nsWebShell::Destroy(nsWebShell * const 0x0175f0c4) line 3055
nsXULWindow::Destroy(nsXULWindow * const 0x0175d934) line 401
nsWebShellWindow::Close(nsWebShellWindow * const 0x0175d98c) line 385
nsAppShellService::~nsAppShellService() line 100
nsAppShellService::`scalar deleting destructor'() + 15 bytes
nsAppShellService::Release(nsAppShellService * const 0x00eae7e0) line 107 + 133 
bytes
DeleteEntry(nsHashKey * 0x00eae760, void * 0x00eae7a0, void * 0x00000000) line 
210 + 18 bytes
_hashEnumerateRemove(PLHashEntry * 0x00eae720, int 59, void * 0x0012fdcc) line 
227 + 26 bytes
PL_HashTableEnumerateEntries(PLHashTable * 0x00ae4140, int (PLHashEntry *, int, 
void *)* 0x10014550 _hashEnumerateRemove(PLHashEntry *, int, void *), void * 
0x0012fdcc) line 368 + 15 bytes
nsHashtable::Reset(int (nsHashKey *, void *, void *)* 0x1004f7a0 
DeleteEntry(nsHashKey *, void *, void *), void * 0x00000000) line 243 + 20 bytes
nsObjectHashtable::Reset() line 347
nsObjectHashtable::~nsObjectHashtable() line 313
nsObjectHashtable::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsServiceManagerImpl::~nsServiceManagerImpl() line 235 + 31 bytes
nsServiceManagerImpl::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsServiceManagerImpl::Release(nsServiceManagerImpl * const 0x00ae41e0) line 244 
+ 152 bytes
nsServiceManager::ShutdownGlobalServiceManager(nsIServiceManager * * 0x00000000) 
line 484 + 17 bytes
NS_ShutdownXPCOM(nsIServiceManager * 0x00000000) line 597 + 7 bytes
main(int 2, char * * 0x00ae4610) line 906 + 8 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e87903()
Group: netscapeconfidential?
brendan, jband, travis, one of you guys broke us.  Can you please take a look?
Assignee: cathleen → dougt
*** Bug 34067 has been marked as a duplicate of this bug. ***
Why is this bug confidential? The PSM is available on a public link, and all of 
the code on the stack is public mozilla code.

Failing a positive reason to keep this bottled up I'll unblock it tomorrow.

ssu: the crash you experienced on shutdown is bug 31695, an unrelated clean-up 
ordering bug. If you had gone to some other page before exiting you would have 
avoided the crash.
dveditz, these are the same bug.
what's the url to get the right psm?
Installation succeeds for me on linux with jband's latest.

I still get a lot of the following, though, which can't be good:
###!!! ASSERTION: ArenaImpl not thread-safe: 'owningThread ==
NS_CurrentThread()', file nsDebug.cpp, line 372

And why is this netscape confidential? this all happens with mozilla-only and
iplanet public binaries...
What are the same bug? Sean's stack trace is clearly bug 31695 which is a well 
defined problem and quite distinct from this one. The stack traces are nothing 
alike.
I'm going to mark this as fixed... i can install with jband's checkin.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Reopening. The 2000040309 build has this problem again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
*** Bug 34067 has been marked as a duplicate of this bug. ***
As threatened I'm marking this public since no one has provided any reasons for 
privacy. Let's not end up like the US gov't where the default is "secret unless 
proved otherwise".
Group: netscapeconfidential?
Is this a unix only problem?  I can not reproduce this on windows.  Adjusting 
platform
OS: Windows NT → Linux
junruh, is the stack the same? Or is it just an exit? If it's an exit, it's
probably the bug that putterman checked in a fix for this afternoon.
Severity: blocker → critical
leaf, do you have a new build with that change?
Nice.  I don't even crash.  I just exit when I trigger.

I do see some javascript errors when loading this page.  This could be 
the cause of the trigger failing??  I am going to try some of our 
xpinstall tests.

Here are the js errors:

JavaScript Error: ReferenceError: section is not defined
URL: http://docs.iplanet.com/scripts/header.js
Line number: 163
 
Document http://www.mozilla.org/ loaded successfully
Document: Done (7.027 secs)
JavaScript Error: ReferenceError: intl_on is not defined
URL: http://docs.iplanet.com/scripts/header.js
Line number: 129
 
JavaScript Error: ReferenceError: intl_off is not defined
URL: http://docs.iplanet.com/scripts/header.js
Line number: 145
 
JavaScript Error: ReferenceError: about_on is not defined
URL: http://docs.iplanet.com/scripts/header.js
Line number: 129
 
JavaScript Error: ReferenceError: about_off is not defined
URL: http://docs.iplanet.com/scripts/header.js
Line number: 145
okay, the js errors have little to due with the problem.  I just tried 
triggering from jimbob, that that exits.  The last thing I see is:

Adding element 0 : _blank

#0  0x4029e709 in nsCOMPtr<nsIPresShell>::StartAssignment (this=0xbfe02050)
    at ../../dist/include/nsCOMPtr.h:641
#1  0x4029b894 in nsGetterAddRefs<nsIPresShell>::operator nsIPresShell ** (
    this=0xbfe0204c) at ../../dist/include/nsCOMPtr.h:887
#2  0x4118501f in nsBoxLayoutState::PushStackMemory (this=0xbfe022a8)
    at nsBoxLayoutState.cpp:371
#3  0x4118872c in nsSprocketLayout::Layout (this=0x8a22648, aBox=0x8a1ff84,
    aState=@0xbfe022a8) at nsSprocketLayout.cpp:98
#4  0x41187b72 in nsContainerBox::Layout (this=0x8a1ff84,
    aBoxLayoutState=@0xbfe022a8) at nsContainerBox.cpp:488
#5  0x41195e19 in nsBoxFrame::Layout (this=0x8a1ff4c, aState=@0xbfe022a8)
    at nsBoxFrame.cpp:793
#6  0x4118ba83 in nsStackLayout::Layout (this=0x8a1f950, aBox=0x8a1fee4,
    aState=@0xbfe022a8) at nsStackLayout.cpp:224
#7  0x41187b72 in nsContainerBox::Layout (this=0x8a1fee4,
    aBoxLayoutState=@0xbfe022a8) at nsContainerBox.cpp:488
#8  0x41195e19 in nsBoxFrame::Layout (this=0x8a1feac, aState=@0xbfe022a8)
    at nsBoxFrame.cpp:793
#9  0x4119589d in nsBoxFrame::Reflow (this=0x8a1feac, aPresContext=0x868e280,
    aDesiredSize=@0xbfe023f8, aReflowState=@0xbfe02350, aStatus=@0xbfe025cc)
    at nsBoxFrame.cpp:661
#10 0x41182182 in nsRootBoxFrame::Reflow (this=0x8a1feac,
    aPresContext=0x868e280, aDesiredSize=@0xbfe023f8,
---Type <return> to continue, or q <return> to quit---
    aReflowState=@0xbfe02350, aStatus=@0xbfe025cc) at nsRootBoxFrame.cpp:204
#11 0x40f6d395 in nsContainerFrame::ReflowChild (this=0x8a1fe70,
    aKidFrame=0x8a1feac, aPresContext=0x868e280, aDesiredSize=@0xbfe023f8,
    aReflowState=@0xbfe02350, aX=0, aY=0, aFlags=0, aStatus=@0xbfe025cc)
    at nsContainerFrame.cpp:613
#12 0x40fbdc37 in ViewportFrame::Reflow (this=0x8a1fe70,
    aPresContext=0x868e280, aDesiredSize=@0xbfe02594,
    aReflowState=@0xbfe024ec, aStatus=@0xbfe025cc) at nsViewportFrame.cpp:544
#13 0x40fa2df2 in PresShell::ResizeReflow (this=0x8937fb8, aWidth=5745,
    aHeight=4155) at nsPresShell.cpp:1608
#14 0x40fa835f in PresShell::ResizeReflow (this=0x8937fb8, aView=0x8982ba0,
    aWidth=5745, aHeight=4155) at nsPresShell.cpp:3528
#15 0x414e9ec6 in nsViewManager2::SetWindowDimensions (this=0x86ee678,
    width=5745, height=4155) at nsViewManager2.cpp:415
#16 0x414ec297 in nsViewManager2::DispatchEvent (this=0x86ee678,
    aEvent=0xbfe0278c, aStatus=0xbfe026b4) at nsViewManager2.cpp:1213
#17 0x414d7514 in HandleEvent (aEvent=0xbfe0278c) at nsView.cpp:68
#18 0x40700e36 in nsWidget::DispatchEvent (this=0x8937e90, aEvent=0xbfe0278c,
    aStatus=@0xbfe02750) at nsWidget.cpp:1418
#19 0x40700a5c in nsWidget::DispatchWindowEvent (this=0x8937e90,
    event=0xbfe0278c) at nsWidget.cpp:1309
#20 0x406ff1a7 in nsWidget::OnResize (this=0x8937e90,
    event={<nsGUIEvent> = {<nsEvent> = {eventStructType = 140 '\214',
---Type <return> to continue, or q <return> to quit---
          message = 1095731964, point = {x = 144190368, y = 1081128848},
          refPoint = {x = -1075828989, y = 103}, time = 0, flags = 0},
        widget = 0x401a08e4, nativeMsg = 0x403d465c}, windowSize = 0x0,
      mWinWidth = 383, mWinHeight = 143883920}) at nsWidget.cpp:623
#21 0x4070bb0b in nsWindow::Resize (this=0x8937e90, aWidth=383, aHeight=277,
    aRepaint=1) at nsWindow.cpp:2414
#22 0x414da1bd in nsView::SynchWidgetSizePosition (this=0x8982ba0)
    at nsView.cpp:896
#23 0x414ef956 in nsViewManager2::ProcessWidgetChanges (this=0x86ee678,
    aView=0x8982ba0) at nsViewManager2.cpp:2646
#24 0x414ef91b in nsViewManager2::CacheWidgetChanges (this=0x86ee678, aCache=0)
    at nsViewManager2.cpp:2637
#25 0x40fa303b in PresShell::ResizeReflow (this=0x8937fb8, aWidth=5745,
    aHeight=4155) at nsPresShell.cpp:1646
#26 0x40fa835f in PresShell::ResizeReflow (this=0x8937fb8, aView=0x8982ba0,
    aWidth=5745, aHeight=4155) at nsPresShell.cpp:3528
#27 0x414e9ec6 in nsViewManager2::SetWindowDimensions (this=0x86ee678,
    width=5745, height=4155) at nsViewManager2.cpp:415
#28 0x414ec297 in nsViewManager2::DispatchEvent (this=0x86ee678,
    aEvent=0xbfe02ba4, aStatus=0xbfe02acc) at nsViewManager2.cpp:1213
#29 0x414d7514 in HandleEvent (aEvent=0xbfe02ba4) at nsView.cpp:68
#30 0x40700e36 in nsWidget::DispatchEvent (this=0x8937e90, aEvent=0xbfe02ba4,
    aStatus=@0xbfe02b68) at nsWidget.cpp:1418
---Type <return> to continue, or q <return> to quit---


The stack is very very deep, that that cause the crash.  This is NOT an 
xpinstall bug.  Need to find an owner for this.
I did not add the entire stacks.  It goes out to well over 2000.
troy, something funny happening with layout on linux.  do you have any ideas?

This bug morphed a few times.  Just take a look after junruh@netscape.com 
comment on 2000-04-03 10:49.
Assignee: dougt → troy
Status: REOPENED → NEW
nevermind this was fixed by eric this afternoon.
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Build: 2000-04-03-15-M15(LINUX)

Install engine back to normal
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.