crash whenever i view this site

VERIFIED WORKSFORME

Status

Camino Graveyard
Plug-ins
--
critical
VERIFIED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Daniel Drucker, Unassigned)

Tracking

({crash})

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Whenever I view this site, Camino crashes. It usually takes about a minute or so.

Reproducible: Always

Steps to Reproduce:
1. navigate to dcwaterjet.com
2. wait 
3. crash!
(Reporter)

Comment 1

12 years ago
Created attachment 225068 [details]
crash report

Comment 2

12 years ago
What version of Camino?

Have you tried a fresh profile?

Does it happen in all versions of Camino? Does it happen in any other browser?

cl
(Reporter)

Comment 3

12 years ago
Version 2006060904. 

I've tried a fresh profile, and I've tried on a machine that had previously never had Camino on it. It does not happen in Firefox, it does not happen in Safari.
(Reporter)

Comment 4

12 years ago
The crash generally happens upon leaving the site; maybe it has to do with unloading of the java-based animation at the top of the page?

Comment 5

12 years ago
I also experience this crash with the latest June 9 nightly build of Camino [2006060904 (v1.0+)] and a fresh profile running on 10.3. Firefox 1.5 does not crash, nor does Safari or Internet Explorer. 

However, before showing anything more than the blue page background, IE does pause for about twenty seconds, which is roughly the same amount of time it takes Camino to crash. That makes me vaguely suspicious of the Java applet on the front page... except that (A) it doesn't crash any of the other browsers I have installed, and (B) I have J2RE 1.4.2 on 10.3 and dmd has 1.5.0 on 10.4.

Comment 6

12 years ago
For either of you who can repro the crash: does it happen in either 1.0, 1.0.1, or 1.0.2rc?

cl

Comment 7

12 years ago
(In reply to comment #5)
> have installed, and (B) I have J2RE 1.4.2 on 10.3 and dmd has 1.5.0 on 10.4.

Actually, the crash log looks like 1.4.2 as well.

Daniel: can you confirm that switching to J2RE 5.0 (use the Java Preferences app) solves the problem?

cl
(Reporter)

Comment 8

12 years ago
Yes, switching to 5 appears to solve the problem.

Comment 9

12 years ago
CCing Steven for advice.
*** Bug 338339 has been marked as a duplicate of this bug. ***
I can't reproduce this bug (I tested with the Camino
2006-06-09-04-1.1-M1.8 nightly, on OS X 10.4.6 (PPC), using both Java
1.5/5.0 and Java 1.4.2).  But with more precise information about how
to trigger it, I may yet be able to.

> The crash generally happens upon leaving the site

Please be more precise.  Does it happen when you click the back button
(to go to a previous page if there is one), or when you enter a new
site in the location bar?  Does it happen when you close the tab (or
the window) for your URL?  Does it happen when you quit Camino (with a
window or tab open that contains the URL)?  Some combination of the
above?

As noted in comment #10, I've found another report with (almost)
precisely the same crash log (attachment 224555 [details]), but reported on
SeaMonkey.  So this bug (whatever it turns out to be) is likely not
just a problem with Camino.

Finally, I've found a dumb mistake in my code (introduced in JEP
0.9.5+d) that _might_ explain the problem.  But JEP 0.9.5+d has been
out for a while (I released it on 2006-03-13), and this crash has very
few reports (so far only two), so it must be quite unusual for my
mistake to have bad consequences.  (The current JEP version, which
still has my mistake, is JEP 0.9.5+e.)
(Reporter)

Comment 12

12 years ago
Oddly, since switching to 1.5, I can't get it to crash *even when I switch back to 1.4*. (Even if I clear out temporary files.)
Here's a slightly off-the-wall suggestion:  Try loading a plugin that
uses the QuickTime DivX decoder (in /Library/QuickTime/DivX
Decoder.component/Contents/MacOS/DivX Decoder), and see if doing so
makes this crash (the one reported here) more likely.

I actually don't know what kind of plugin uses this decoder.  But (as
far as I can tell) it's the one "non-standard" library that shows up
in both crash logs' lists of shared libraries.

(By the way, loading one of the QuickTime movie trailers at
http://www.apple.com/trailers/ _doesn't_ load this DivX decoder.)
This DivX Decoder isn't (apparently) part of QuickTime -- instead it's a
separate, semi-commercial utility that can be used with QuickTime
(http://www.divx.com/divx/mac/codec/).  The current version is 6.2.
What's the status here?  Should we close this WORKSFORME now, or does it still crash, or?
Severity: normal → critical
Component: General → Plug-ins
Keywords: crash
QA Contact: general → plugins
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.