Firefox 1.5.0.4 crashes upon startup with Netcraft toolbar installed and enabled [@ nsHTMLDocument::MatchLinks]

RESOLVED DUPLICATE of bug 326645

Status

()

--
critical
RESOLVED DUPLICATE of bug 326645
13 years ago
8 years ago

People

(Reporter: bwmartin, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

My Firefox browsers recently updated to version 1.5.0.4.

Since that time I get a Windows error every time I start Firefox.  The error is:  "firefox.exe has encountered a problem and needs to close.  We are sorry for the inconvenience."

If I restart Firefox in safe mode and disable or uninstall the Netcraft toolbar (v. 1.1.1.3)  the problem goes away.  (It also goes away if I reinstall version 1.5.0.3 of Firefox--in other words, if I revert to the previous version of Firefox.)



Reproducible: Always

Steps to Reproduce:
1. Have Netcraft toolbar installed
2.  Allow Firefox to update from v. 1.5.0.3 to 1.5.0.4.
3.  restart Firefox

Actual Results:  
Upon starting Firefox receive the Windows error "firefox.exe has encountered a problem and needs to close.  We are sorry for the inconvenience."

Expected Results:  
Expect Firefox to restart properly and to load the netcraft toolbar extension.

Comment 1

13 years ago
Netcraft toolbar works fine for me in 1.5.0.4 on Windows XP.

Do you have a talkback ID? http://kb.mozillazine.org/Talkback
Keywords: crash
(Reporter)

Comment 2

13 years ago
Additional information:  I have three computers all running Windows XP, Firefox 1.5.0.4, and Netcraft toolbar v. 1.1.1.3.  Two of them have the problem that I reported and one does not.

UPDATE:  By email Netcraft support told me that their only other report of this happening was from a user who was also running the Google Web Accelerator.  I am running Google Web Accelerator as well.  I have now disabled it and the Netcraft toolbar now works fine.  There must be some sort of conflict between Netcraft toolbar and Google Web Accelerator--although they worked together fine in previous versions of Firefox.

Comment 3

13 years ago
oh, this will be so much fun.

since you're on windows, ideally we should be able to get .pdb files from:
mozilla (or an equiv. i.e. mcsmurf)
microsoft (public symbol server available)
google
netcraft

talkback alone is unlikely to shed much light on this, but please do report.

the starting point for better than talkback is:
http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg

although the article needs to mention
!analyze -v -f
and
.dump (/msg word .dump? for my preferred flags)

it wouldn't be too hard for you to generate a dump which was populated with the (microsoft)windows and (mcsmurf)mozilla symbols and then pass it around to the netcraft/google people to add their own symbols, assuming they have, and it would be possible for them to trim out pdb files which they don't feel are necessary. (there are also 2 kinds of pdbs, public and private, so they could pass out the public flavor for the one or two dlls that mattered.)

but I'll walk people through those steps later if we can get people on the same page.

I'm going to move this to networking because that's where GWA generally plays (iirc)...
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
Version: unspecified → 1.8 Branch

Comment 4

13 years ago
[Removing email addresses for people who no longer work here!]

The Netcraft Toolbar is pure javascript/xul - no native code - so no symbols needed from us.

jez

Comment 5

13 years ago
jez: thanks.

so, mcsmurf tried this and his talkback incident (TB19818027Q) seems to be
http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/content/html/document/src/nsHTMLDocument.cpp&mark=1733&rev=FIREFOX_1_5_0_4_RELEASE#1733

which doesn't seem to match bug 340796.

*** This bug has been marked as a duplicate of 326645 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 7

13 years ago
Incident ID: 19818027
Stack Signature	nsHTMLDocument::MatchLinks bfa69653
Product ID	Firefox15
Build ID	2006050817
Trigger Time	2006-06-13 03:28:24.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	firefox.exe + (001b2d8d)
URL visited	
User Comments	
Since Last Crash	689 sec
Total Uptime	689 sec
Trigger Reason	Access violation
Source File, Line No.	c:/builds/tinderbox/Fx-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/content/html/document/src/nsHTMLDocument.cpp, line 1733
Stack Trace 	
nsHTMLDocument::MatchLinks  [c:/builds/tinderbox/Fx-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/content/html/document/src/nsHTMLDocument.cpp, line 1733]
Component: Networking → DOM: HTML
QA Contact: networking → ian
Summary: Firefox 1.5.0.4 crashes upon startup with Netcraft toolbar installed and enabled → Firefox 1.5.0.4 crashes upon startup with Netcraft toolbar installed and enabled [@ nsHTMLDocument::MatchLinks]

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: ian → general
(Assignee)

Updated

8 years ago
Crash Signature: [@ nsHTMLDocument::MatchLinks]
You need to log in before you can comment on or make changes to this bug.