cityofchicago.org - doesn't meet its own guidelines re: standards-compliance

RESOLVED WONTFIX

Status

--
minor
RESOLVED WONTFIX
13 years ago
4 years ago

People

(Reporter: Wulf, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: 

Doesn't meet its own guidelines (the Illinois Web Accessibility Standard, http://egov.cityofchicago.org/webportal/COCWebPortal/COC_ATTACH/iwas1_2.pdf, excerpt below... Page linked to from bottom of all pages, re: cityofchicago.org's use of the standards = http://egov.cityofchicago.org/city/webportal/portalGeneralMessageAction.do?oid=536912292&Failed_Reason=Invalid+timestamp,+engine+has+been+restarted&com.broadvision.session.new=Yes&Failed_Page=%2fwebportal%2fportalGeneralMessageAction.do) regarding standards compliance...

http://egov.cityofchicago.org/city/webportal/portalGeneralMessageAction.do?oid=536912292&Failed_Reason=Invalid+timestamp,+engine+has+been+restarted&com.broadvision.session.new=Yes&Failed_Page=%2fwebportal%2fportalGeneralMessageAction.do gives contact info, but I'm really busy, so it would be best if somebody else contacted them.

Thanks,
Wulf

Reproducible: Always

Steps to Reproduce:
1. Try to validate their main page (http://egov.cityofchicago.org/city/webportal/home.do)
2. it won't work due to the fact that they specified a non-existent character encoding (8859_1)
3. Override the encoding to ISO-8859-1.
4. Fails validation, 387 errors as of the time I posted this...
Actual Results:  
HTML doesn't validate with W3C, breaking the standards they say they abide by.

Expected Results:  
HTML validates.

Illinois Web Accessibility Standard (http://egov.cityofchicago.org/webportal/COCWebPortal/COC_ATTACH/iwas1_2.pdf)

1.1 – Use valid, standard web programming code.

What: The World Wide Web Consortium (W3C) sets and publishes standards for most web programming languages, including HTML 4.01, XHTML 1.0, CSS Level 1 & 2, DOM, and SMIL. Programming code is considered "valid" when it follows the all the rules and conventions specified in the published standards.

Why: Screen readers and other assistive technologies can more accurately interpret and interact with web pages that are built using valid, standard code. W3C languages are designed with accessibility in mind.

How: Indicate the programming language you are using by starting your code with a document type declaration such as: <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> Use the W3C HTML Validation Service (http://validator.w3.org) and W3C CSS Validation Service (http://jigsaw.w3.org/css-validator) to check your code. Refer to the World Wide Web Consortium site (http://www.w3.org) for full specifications and documentation.

Ref: WCAG 3.2, 11.1

Comment 1

11 years ago
While standards-compliance is an admirable goal, TE has more important things to worry about, like the 5000 or so sites for which there are open bugs due to those sites being nonfunctional in Gecko browsers. Maybe once all those bugs are FIXED, we can worry about this one. Until then, this is a WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.