scrollbars on westlaw windows don't show where they should

VERIFIED DUPLICATE of bug 311454

Status

VERIFIED DUPLICATE of bug 311454
12 years ago
12 years ago

People

(Reporter: langer.property, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.3) Gecko/20060427 Camino/1.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.3) Gecko/20060427 Camino/1.0.1

scroll bars don't show on window menus on carswell's westlaw site ecarswell.westlaw.com for eg. "By Jurisdiction" menu is not fully accessible

Reproducible: Always

Steps to Reproduce:
1.log into westlaw
2.go to LawSource
3.

Actual Results:  
window menus not displaying properly

Expected Results:  
see the same page on Safari, which displays properly

Comment 1

12 years ago
Unfortunately, since this requires a login, there's probably not too much we can do here.  However, there are a couple things you could try to narrow down the problem:

Does it work with the most recent release of Firefox?  If so, does spoofing your user-agent string as Firefox solve the problem?
It's possible we know someone who might have a login, but if not, saving the page as HTML Complete as described in the Camino Bugzilla FAQ might provide us useful information if the suggestions in comment 1 don't cause the site to work.  See http://www.caminobrowser.org/support/bugzilla/#login for instructions on saving as HTML Complete.

Comment 3

12 years ago
Yup, I see this.  It's a <select size="4">.  That makes this a dup of bug 340204, but that's really only the latest open bug for this oft-reported issue.  It's generally considered to be a WONTFIX, because even though we'd like to fix it, there's really nothing anyone who's looked at the problem so far is able do about it.  The scrollbar is too small for the OS, and when you ask the OS to draw it, it doesn't.

It would be nice to handle this case a little more gracefully in nsNativeScrollbar, because 4's not an unreasonably small size for a <select> listbox.  Follow up in the other bug.  So ordered.

*** This bug has been marked as a duplicate of 311454 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 4

12 years ago
Created attachment 225242 [details]
HTML source snippet (for reference)

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.