When searching with Opera, and identifying as Mozilla, searching a bugzilla database stalls.

RESOLVED INVALID

Status

()

Bugzilla
Query/Bug List
--
minor
RESOLVED INVALID
12 years ago
4 years ago

People

(Reporter: Dave Suffling, Assigned: Simon Green)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Opera/9.00 (X11; Linux i686; U; en)
Build Identifier: Opera 9.00 Beta 2 Build 284 (Linux i686, 2.6.15-23-686)

Opera can identify itself (User-Agent field in the HTTP request) as Mozilla, as a workaround to sites which are programed to only work with Mozilla or IE. If this feature is accedentally left on, and a user attempts to search bugzilla, the search will never complete. (The status bar indicates that Opera is loading image 0 of 0.) However, if Opera is set to identify as Opera, the search executes successfully. 

Because the cause of this problem is non-obvious, and because Opera does identify itself as such even when masquerading as Mozilla, I would suggest that this should still be considered a Bugzilla bug. 

Until recently, Opera's default behavior was to identify as Mozilla. 

Reproducible: Always

Steps to Reproduce:
Switch Opera to "Identify as Mozilla". Attempt to search for a bug by keyword.

Actual Results:  
The page is "loading" ad infinitum. No content is displayed. 


User-Agent string when identifying as Opera:

Opera/9.00 (X11; Linux i686; U; en)

User-Agent string when identifying as Mozilla:

Mozilla/5.0 (X11; Linux i686; U; en) Opera 9.00

Comment 1

12 years ago
What version of Bugzilla did this occur on? We should be correctly detecting Opera.

I suppose Opera doesn't support server-push, which is what this would mean.
OS: Linux → All
Hardware: PC → All
(Reporter)

Comment 2

12 years ago
I'm not sure the version. I was filling on bugzilla.mozilla.org.

-DS

b.m.o is using Bugzilla version 2.20, but this will affect all versions I know of.

I'd say comment 1 is spot on. If Opera identifies itself as Mozilla, Bugzilla expects the browser to be Mozilla-compatible, and will use certain Mozilla-specific features. Server-push is one of those.

Is this WORKSFORME or INVALID?

Comment 4

12 years ago
(In reply to comment #3)
> Is this WORKSFORME or INVALID?

  Depends if it actually happens or if it's just some anomaly that the user is experiencing. It might be a valid bug. We can always tell if Opera is Opera, even if it's pretending to be Mozilla.
http://lxr.mozilla.org/mozilla/source/webtools/bugzilla/buglist.cgi#124 shows how it's currently done. Opera is not special-cased, but apparently needs to be.

Should Opera decide for some reason to identify itself as "Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4" or something, it will break again.
Whiteboard: [Good intro bug]
(Reporter)

Comment 6

12 years ago
Whatever the technical situation is, I strongly feel that Opera masquerading should be supported, since so many Opera users are forced to masquerade as Mozilla to get around the web. 

The simple fact is that Opera is a very capable browser (no disrespect to Mozilla browsers) and can handle most content on the web -- if it's treated as a first-class browser. Many sites even go as far as to send all non-IE, non-Mozilla browsers text-only versions. Opera user claiming to be using Mozilla get a lot more mileage in many cases. This is one of the only cases I know of where Opera masquerading as Mozilla does *not* work perfectly.

Moreover, many versions of Opera identify is Mozilla by default. Bugzilla should operate properly with the default configuration of Opera, even if it is only a few percent of the market share. 

Sorry for the rant, but I feel it's important to keep the web open, and let people choose what software they want to work with. 

-DS
I'm sorry if my comment was misleading. I was pointing out the place where to fix Bugzilla, as a possible first step for a patch.

Comment 8

12 years ago
Okay. Confirmed as per wurblzap's comment.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

8 years ago
works for me on Opera 10.0 at this site with 'Identify as Firefox' on
(Assignee)

Comment 10

4 years ago
I _suspect_ this is because Bugzilla uses Server Push for Mozilla, when Opera didn't support it. Opera now supports this feature, so it should work. Since there has been no mention in the last 3½ years, I'm going to close this bug. Please reopen if it is still an issue with the latest version of Opera.

http://en.wikipedia.org/wiki/Push_technology#HTTP_server_push
Assignee: query-and-buglist → hugo.seabrook
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID

Updated

4 years ago
Whiteboard: [Good intro bug]
You need to log in before you can comment on or make changes to this bug.