Windows clipboard datas are deleted when opening a new Firefox window

VERIFIED INVALID

Status

()

--
major
VERIFIED INVALID
12 years ago
12 years ago

People

(Reporter: mae, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Firefox deletes our windows clipboard data whenever a new firefox
window is opened. It's really nice, and cool as a feature .. . but i only need
to get rid of my clipboard's data "Intentionally"

Side effects: I have to recopy a second time what i previously copied on my
desktop before opening a new firefox window

Reproducible: Always

Comment 1

12 years ago
WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4 ID:2006050817
Can you provide some steps to reproduce (how do you open the new window)?
Did you try with a clean profile or in safe-mode?
Summary: Someone asserted me that this bug would be fixed in 1.5.0.4 "DELETED CLIPBOARD BY FIREFOX NEW WINDOWS" → Windows clipboard datas are deleted when opening a new Firefox window
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4)
> Gecko/20060508 Firefox/1.5.0.4 ID:2006050817
> Can you provide some steps to reproduce (how do you open the new window)?
> Did you try with a clean profile or in safe-mode?
> 


1. copy oe's spam full headers to the clipboard (select-right click-copy)

2. click on the quick launch firefox's icon to start a new firefox window

3. when the new window arrived on the screen, even without going to spamcop.com to paste my headers, the clipboatrd content was gone ))

This was an exemple you requested ... .

Ps: Note that any form of data added to the clipboard, will be deleted
by firefox after opening a new firefow window .. .

And no, i didn't try the safe mode as i don't need 
to run firefox in safe mode.

Alias: _

Comment 3

12 years ago
(In reply to comment #2)
> 1. copy oe's spam full headers to the clipboard (select-right click-copy)
> 2. click on the quick launch firefox's icon to start a new firefox window
> 3. when the new window arrived on the screen, even without going to 
> spamcop.com to paste my headers, the clipboatrd content was gone ))
I still can't reproduce. How do you know what is in the clipboard (any clipboard tool)? 

> And no, i didn't try the safe mode as i don't need 
> to run firefox in safe mode.
You should try to reproduce in safe-mode (see http://kb.mozillazine.org/Safe_Mode) or with a brand new profile.

(Reporter)

Comment 4

12 years ago
(In reply to comment #1)
> WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4)
> Gecko/20060508 Firefox/1.5.0.4 ID:2006050817
> Can you provide some steps to reproduce (how do you open the new window)?
> Did you try with a clean profile or in safe-mode?
> 


1. copy oe's spam full headers to the clipboard (select-right click-copy)

2. click on the quick launch firefox's icon to start a new firefox window

3. when the new window arrived on the screen, even without going to spamcop.com to paste my headers, the clipboatrd content was gone ))

This was an exemple you requested ... .

Ps: Note that any form of data added to the clipboard, will be deleted
by firefox after opening a new firefow window .. .

And no, i didn't try the safe mode as i don't need 
to run firefox in safe mode.

(In reply to comment #3)
> (In reply to comment #2)
> > 1. copy oe's spam full headers to the clipboard (select-right click-copy)
> > 2. click on the quick launch firefox's icon to start a new firefox window
> > 3. when the new window arrived on the screen, even without going to 
> > spamcop.com to paste my headers, the clipboatrd content was gone ))
> I still can't reproduce. How do you know what is in the clipboard (any
> clipboard tool)? 
> 
> > And no, i didn't try the safe mode as i don't need 
> > to run firefox in safe mode.
> You should try to reproduce in safe-mode (see
> http://kb.mozillazine.org/Safe_Mode) or with a brand new profile.
> 



Or totally uninstall and iradicate firefox from the hard drive .. .

Good workaround but,i don't think i would even know what really
does that by using a new profile .. .

Comment 5

12 years ago
(In reply to comment #4)
> Or totally uninstall and iradicate firefox from the hard drive .. .
> 
> Good workaround but,i don't think i would even know what really
> does that by using a new profile .. .
Keep cool, I'm just trying to help you even if bugzilla is not the good place to ask for support.
I asked you to try to reproduce with a new profile (or safe-mode) to see if it's extension related. 


(Reporter)

Comment 6

12 years ago
(In reply to comment #1)
> WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4)
> Gecko/20060508 Firefox/1.5.0.4 ID:2006050817
> Can you provide some steps to reproduce (how do you open the new window)?
> Did you try with a clean profile or in safe-mode?
> 


1. copy oe's spam full headers to the clipboard (select-right click-copy)

2. click on the quick launch firefox's icon to start a new firefox window

3. when the new window arrived on the screen, even without going to spamcop.com to paste my headers, the clipboatrd content was gone ))

This was an exemple you requested ... .

Ps: Note that any form of data added to the clipboard, will be deleted
by firefox after opening a new firefow window .. .

And no, i didn't try the safe mode as i don't need 
to run firefox in safe mode.

(In reply to comment #3)
> (In reply to comment #2)
> > 1. copy oe's spam full headers to the clipboard (select-right click-copy)
> > 2. click on the quick launch firefox's icon to start a new firefox window
> > 3. when the new window arrived on the screen, even without going to 
> > spamcop.com to paste my headers, the clipboatrd content was gone ))
> I still can't reproduce. How do you know what is in the clipboard (any
> clipboard tool)? 
> 
> > And no, i didn't try the safe mode as i don't need 
> > to run firefox in safe mode.
> You should try to reproduce in safe-mode (see
> http://kb.mozillazine.org/Safe_Mode) or with a brand new profile.
> 



Or totally uninstall and iradicate firefox from the hard drive .. .

Good workaround but,i don't think i would even know what really
does that by using a new profile .. .
(In reply to comment #5)
> (In reply to comment #4)
> > Or totally uninstall and iradicate firefox from the hard drive .. .
> > 
> > Good workaround but,i don't think i would even know what really
> > does that by using a new profile .. .
> Keep cool, I'm just trying to help you even if bugzilla is not the good place
> to ask for support.
> I asked you to try to reproduce with a new profile (or safe-mode) to see if
> it's extension related. 
> 


im afraid to mess with my extenssions configs and not get them back by removing and reinstalling extenssions ..... im not mad at u dude, im just scared cuz some extensions needed a lot of time like the menu editor ..... .

Comment 7

12 years ago
(In reply to comment #6)
> im afraid to mess with my extenssions configs and not get them back by removing
> and reinstalling extenssions ..... im not mad at u dude, im just scared cuz
> some extensions needed a lot of time like the menu editor ..... .
Just follow the instruction on http://kb.mozillazine.org/Safe_Mode, take care that nothing is checked and click "Continue in Safe Mode" and nothing else. Next Firefox start will be in normal mode with all your settings/etc.

PS: can you stop quoting all the discussion. 

(Reporter)

Comment 8

12 years ago
TO FIND WHAT EXTNSION DOES THAT, I WILL NEED TO UNINSTALL THEM OR INSTLL THEM ALL ONE BY ONE ... . ITS TOO MESSY I MUST HAVE 10 EXTENSIONS OR SO

Comment 9

12 years ago
(In reply to comment #8)
> TO FIND WHAT EXTNSION DOES THAT, I WILL NEED TO UNINSTALL THEM OR INSTLL THEM
> ALL ONE BY ONE ... . ITS TOO MESSY I MUST HAVE 10 EXTENSIONS OR SO
Arf, you can ask for support in http://forums.mozillazine.org or on irc at irc.mozilla.org/firefox.


Ria, could you try to reproduce? 

I can't reproduce this whenever I want but it happens very often that I copy a link, run several browsers subsequently and after pasting it for the second, third or fourth time suddenly my clipboard is empty so I need to go back to maximize the browser where I copied the link. And I'm quite certain that I did not copy a picture in the mean time. It makes no difference which build I use; it happens in trunk as well and everything with new clean profiles etc. :)
It does certainly not occur every time, mostly the link is still present in my clipboard after pasting it for the 10th time or so.
There are several clipboard bugs and I've lost track which kind of clipboard problem belongs to what bug.
See http://kb.mozillazine.org/Clipboard_not_working

Comment 11

12 years ago
(In reply to comment #10)
Thanks Ria.

 -> dupe of bug 284174 ?

(Reporter)

Comment 12

12 years ago
popupshow.dll or pushowxx.dll I DO NOT HAVE THAT, I CHECK FOR NEW DOTNET TRACES, I DON'T SEEM TO HAVE THEM EITHER ... .

I'VE SEEN THAT SITE BEFORE THAT'S WHY I REPORTED THE FACT THAT IN THIS SITE THIS BUG WAS GONNA BE FIXED IN 1 5 0 4 .... .

And it's still not fixed .. .
(Reporter)

Comment 13

12 years ago
I've finally found after many tests what was making firefox delete our clipboard
before opening new windows, in my case, it wasn't an extension as i removed
17 extensions testing firefox without them successively ... .

But outlook 2003 skin for firefox, and why ? i can't tell you since
i'm not the author of that skin, nor a programmer.
(Reporter)

Comment 14

12 years ago
I've finally found after many tests what was making firefox delete our clipboard
before opening new windows, in my case, it wasn't an extension as i removed
17 extensions testing firefox without them successively ... .

But outlook 2003 skin for firefox, and why ? i can't tell you since
i'm not the author of that skin, nor a programmer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

12 years ago
Is there a fix or am i condamned to stop using this nice skin ?
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 16

12 years ago
(In reply to comment #14)
> I've finally found after many tests what was making firefox delete our
> clipboard before opening new windows, in my case, it wasn't an extension
[...]
> But outlook 2003 skin for firefox
So if this is related to one of your theme, this is not a Firefox issue and this is INVALID.
Try to contact the theme author, or ask for support in mozillazine forums, in order to fix your issue. 

Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID
Verified, theme problems should be passed onto the author.
Alias: _
Status: RESOLVED → VERIFIED
(Reporter)

Comment 18

12 years ago
The author's french and doesn't answer by email, ill try the forums even though im not sure theyll give me a real answer, im sad cuz its a lovely theme and it fits well to my ie icons ... .

sad sad sad, thx anyways
You need to log in before you can comment on or make changes to this bug.