tr_new_plan.cgi - not able to edit product version

RESOLVED FIXED

Status

Testopia
Test Plans
--
critical
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Vivek, Assigned: Greg Hendricks)

Tracking

PowerPC
Mac OS X

Details

Attachments

(1 attachment)

158.63 KB, application/pdf
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Hello, 
 
I installed the beta version of testopia, and when running tr_new_plan.cgi to create a new test plan, I am not able to edit product version, it shows blank, and is uneditable, even though there are product versions for all products. And then I get the following error on saving: 
 
Undef to trick_taint at Bugzilla/Util.pm line 63 
Bugzilla::Util::trick_taint('undef') called at tr_new_plan.cgi line 63 
 
Can you please help asap as I upgraded the production instance of test runner to testopia, and don't wish to go back now. 
 
Thanks, 
Vivek

Reproducible: Always

Steps to Reproduce:
1.Login
2.Click to create a test plan
3.Not able to edit product version, and then save the test plan

Actual Results:  
Undef to trick_taint at Bugzilla/Util.pm line 63 
Bugzilla::Util::trick_taint('undef') called at tr_new_plan.cgi line 63 

Expected Results:  
It should have saved the test plan.

Comment 1

12 years ago
Is javascript turned off in your browser? If so, try the same thing with javascript turned on.
(Reporter)

Comment 2

12 years ago
thanks for your email, yes I just checked javascript is turned on. when I look at the javascript console, it gives the following error:

Error: dojo is not defined
Source File: http://xx.xx.com:xxxx/bugzilla/bugzilla2201/tr_new_plan.cgi
Line: 90

(In reply to comment #1)
> Is javascript turned off in your browser? If so, try the same thing with
> javascript turned on.
> 
(Reporter)

Updated

12 years ago
Severity: major → critical
Version: unspecified → 1.0

Comment 3

12 years ago
Greg:

Please take a look at this one.
(Assignee)

Comment 4

12 years ago
There are several possible causes for this. 

Can you verify that you are able to get the dojo.js file to load?

Try pointing your browser at http://xx.xx.com:xxxx/bugzilla/bugzilla2201/testopia/dojo-ajax/dojo.js and verify that you see the javascript.

If that is working it may be a problem with Firefox on Macintosh. I have not tested Testopia on Mac yet. Try hitting the page in Firefox on Linux or Windows and see if you get the same error. 

The version lookup uses ajax (javascript) to load the information. I am working on an alternative to the javascript enabled version of this page. 

Testopia 1.0 is not yet considered production ready (still Beta). 
(Reporter)

Comment 5

12 years ago
Thank you Greg for your email. It could not find dojo.js. I copied js and dojo-ajax sub directories from testopia-1.0-beta/testopia/ to bugzilla2201/Testopia, and then I can see the versions, and no longer get that error.

However, now I get the following error when saving a test plan:

undef error - Can't find param named allow-test-deletion at Bugzilla/Config.pm line 151.

You may want to add copying of dojo-ajax sub directory to the list of install steps. fyi-

thanks,
Vivek
(Reporter)

Comment 6

12 years ago
I just noticed that it adds the plan to the database though it shows the error on browser:

Internal Error

Bugzilla has suffered an internal error. Please save this page and send it to vivek@apple.com with details of what you were doing at the time this message appeared.

URL: http://xx.xx.xx.xx:xxxx/bugzilla/bugzilla2201/tr_new_plan.cgi
undef error - Can't find param named allow-test-deletion at Bugzilla/Config.pm line 151.
(Assignee)

Comment 7

12 years ago
I assume you are using the version of the docs that tells you to copy the files. There is a newer version available with a tarball that you just drop into your installation and then run a script. That is available from the project page at http://www.mozilla.org/projects/testopia/

Once you untar it, run tr_install.pl and it will patch your bugzilla which will remove the undefined paramater error.
(Reporter)

Comment 8

12 years ago
Yes I am using the docs that tells to copy files. I had copied files etc as per those docs, can I still run the tr_install.pl? I had taken the tar yesterday from the website you mention, so I believe I have the latest set of files.

Thanks!

Comment 9

12 years ago
(In reply to comment #8)
> Yes I am using the docs that tells to copy files. I had copied files etc as per
> those docs, can I still run the tr_install.pl? I had taken the tar yesterday
> from the website you mention, so I believe I have the latest set of files.

So you're working with http://www.mozilla.org/projects/testopia/downloads/testopia-1.0-beta.tar.gz ?

Where's this old installation document, that we may delete it?
(Reporter)

Comment 10

12 years ago
Yes, the old install document Manual.pdf is in the root, when you untar the tar file. I noticed new manual in the doc folder in testopia directory which talks about running the perl file.

Can I go ahead and run the perl file even though I have manually copied files etc.? Thanks.

Comment 11

12 years ago
(In reply to comment #10)
> Yes, the old install document Manual.pdf is in the root, when you untar the tar
> file. I noticed new manual in the doc folder in testopia directory which talks
> about running the perl file.
> 
> Can I go ahead and run the perl file even though I have manually copied files
> etc.? Thanks.

Sorry -- I'm still not sure what you have. What's the md5sum of your Manual.pdf? What's the md5sum of the tarball you used to install?

Here's why I'm confused -- the Manual.pdf inside http://www.mozilla.org/projects/testopia/downloads/testopia-1.0-beta.tar.gz contains these instructions:

1. Copy the testopia tar ball into your bugzilla's root directory.
2. Untar
    tar xzvf testopia-<release>.tar.gz
3. Run tr_install.pl
    perl tr_install.pl

Therefore, if your instructions are different, I don't think you're using http://www.mozilla.org/projects/testopia/downloads/testopia-1.0-beta.tar.gz 
(Reporter)

Comment 12

12 years ago
Created attachment 225333 [details]
manual file
(Reporter)

Comment 13

12 years ago
Dear Greg,

I did a fresh install of Testopia, and it worked. I haven't yet fully looked into it, but saw a couple of neat features.

1. When do you plan to have Testopia 1.0 production ready?
2. I noticed bulk save option at some of the places, is there a plan to do a bulk pass or fail of tests in a test run?

Thanks for your help,
Vivek
(Assignee)

Comment 14

12 years ago
(In reply to comment #13)
> Dear Greg,
> 
> I did a fresh install of Testopia, and it worked. I haven't yet fully looked
> into it, but saw a couple of neat features.
> 
Sorry for the confusion. We are still working on getting a release system in place. It looks like you were caught in the mess.

> 1. When do you plan to have Testopia 1.0 production ready?
We are working on fixing the bugs reported in the beta. We hope to have a release candidate by the end of June.

> 2. I noticed bulk save option at some of the places, is there a plan to do a
> bulk pass or fail of tests in a test run?
This is already supported. When you start a run you should see a link at the bottom of the case run log table that says update multiple.

Thank you for your help. If you find any more bugs or have further suggestions please open bugs for them. If you have further questions you can post them to the support-webtools@lists.mozilla.org mailing list or pop into the testopia chatroom at irc.mozilla.org/testopia
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.