Middle-clicking a button on Bookmarks toolbar causes error

RESOLVED DUPLICATE of bug 340966

Status

()

RESOLVED DUPLICATE of bug 340966
13 years ago
13 years ago

People

(Reporter: ventnor.bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060611 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060611 Minefield/3.0a1

Its great that middle-clicking on certain buttons causes them to open in new tabs. However, this doesn't seem to work on buttons in the Bookmarks Toolbar. I middle-clicked Firefox Central and an error message came up. I then added a page to the bookmarks toolbar, tried middle-clicking that, and the same error dialog appears. I have a screenshot, which I will upload as soon as I become Bugzilla literate. 8)

I open up the error console afterwards and see this message:

Error: uncaught exception: [Exception... "Cannot modify properties of a WrappedNative"  nsresult: "0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN)"  location: "JS frame :: chrome://browser/content/places/controller.js :: PC_openLinksInTabs :: line 1338"  data: no]

The strange thing is, when I middle click the "Latest Headlines" button, it all works fine (all the pages are opened). But when I try middle-clicking an item, that blasted error dialog appears.

I suspect it has something to do with the new bookmarks API.

Reproducible: Always

Steps to Reproduce:
1. Middle click Firefox Central in the bookmarks toolbar.

Actual Results:  
Error dialog appears.

Expected Results:  
The bookmark should open in a new tab.
(Reporter)

Comment 1

13 years ago
Created attachment 225234 [details]
This is the exact error I receive when I try middle clicking a button in the bookmarks toolbar.

This is the dialog I receive.

*** This bug has been marked as a duplicate of 340966 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.