Status

www.mozilla.org
General
P3
enhancement
VERIFIED WONTFIX
18 years ago
6 years ago

People

(Reporter: BenB, Assigned: Brian 'netdragon' Bober)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Would be nice, if we could have a "<a href="mylink">myname</a>" instead of just

"myname" in the contributor list. "mylink" (and propably also "myname") could be

any URI and should be configurable by the contributor without much involvement

of mozilla.org.



This could be relatively easily achieved by creating field on the soon-to-be

created mozilla.org LDAP server, which takes "mylink". This field should

propably be only used by credits (at least for now), because I might want to

present different links depending on the audience (the world (credits) or the

mozilla community (e.g. Mozilla-internal webtools)). Maybe call it "public_link"

or so.

Comment 1

18 years ago
To do this would require automating the creation of the credits list.
This can't be done until ldap is set up and fully populated with 
current anf former contributors. This is a fine idea and will make the
credits list more accurate. Marking this as dependent on setting up 
ldap.
Status: NEW → ASSIGNED
Depends on: 34118
This bug has not been touched for more than nine months. In most cases, that 
means it has "slipped through the net". Please could the owner take a moment to 
add a comment to the bug with current status, and/or close it.

Thank you :-)

Gerv
(Reporter)

Comment 3

17 years ago
Gerv, it depends on the LDAP bug.

Anyway, do not close it, unless you think, it were a bad idea.
Severity: normal → enhancement
(Reporter)

Comment 4

17 years ago
oh, a spam comment :-(((. nevermind.

Comment 5

16 years ago
moving to webmaster@mozilla.org

as a side note, i don't think that we can rely on the LDAP server for this..
Status: ASSIGNED → NEW
Component: Miscellaneous → webmaster@mozilla.org
QA Contact: imajes

Comment 6

16 years ago
*** Bug 114756 has been marked as a duplicate of this bug. ***

Updated

14 years ago
QA Contact: imajes → stolenclover
reassigning endico's bugs to default owner
Assignee: endico → mozilla.webmaster

Comment 8

14 years ago
Is there still something we want to do with this file?
No, not really. Apart from this bug, I've never seen anyone else jump up and
down for this feature, and it's hassle. Even the new Firefox/Thunderbird credits
don't have personal links.

So I'd say WONTFIX.

Gerv
(Assignee)

Comment 10

14 years ago
I don't think this should be WONTFIX, but definately not a priority. It is
something that would be very nice. One thing we don't get as open source
developers is enough credit for our work.


This might be better handled 3rd-party initially. Which brings the question:

Gerv: If this were handled 3rd-party initially, and then eventually brought onto
the Mozilla server, which method of authentication would you use? It doesn't
seem necessary to have anything but a .passwd file for user/pass, and a textual
database, and static generated .html file because people wouldn't be logging in
all that often. Would that be sufficient?

The initial setup of this feature would allow for the possibility of impostures
for certain contributors. It would also be too much work to verify the
individuals. Therefore, I think we should just let people create accounts on an
"honor system", and then can arbitrate the cases where an individual acts as an
imposture. The system can also lock out any email addresses that register for
more than one name.
Assignee: mozilla.webmaster → netdragon
Brian: you seem to be under several misapprehensions as to how about:credits
works. Regardless, neither I nor (I suspect) anyone else at mozilla.org has any
cycles to put into this. We wouldn't be using any "methods of authentication",
because it's not going to happen.

Gerv
(Assignee)

Comment 12

14 years ago
After thinking about it, I realize that about:credits might not be the best
place for some better form of acknowledgement for peoples' work. The reason
being that people are not going to go through and click every link for everyone
on about:credits. It would be a good place to actually go and connect to a site
describing what people have done, but this doesn't have to be done in about:credits.

Some individuals studying open source projects have some misconceptions. When
they look at tinderbox, some think that the ones checking in the code were the
actual writers. A lot of the work in this project is done by patchwriters, and
we deserve some acknowledgement for the work we do, even if it's just one patch.
I agree that about:credits wouldn't be the best place for this, and perhaps this
bug should be WONTFIXed in place of using some other method... But just because
someone is too busy to write more than a few patches doesn't mean they should be
ignored. This wouldn't, of course, be bad for the main developers either, but
they don't really have to explain what work they have done because it's easier
to trace.

I think by the way things are set up, Mozilla.org gives the false impression
that patchwriters are not a significant portion of the contributors. Something
should be done to correct this. You can't expect someone in a university
studying open source projects to write a book about them is going to know how to
use Bonsai and Bugzilla to see who really did the work.
(Assignee)

Comment 13

14 years ago
But I want to say that I really do think recognition needs to be addressed in
some manner, even if this is WONTFIXed, because where's the community if you
only recognize the work beyond a name in about:credits, and where's the
incentive if a patchwriter gets little or no recognition for the work he or she
did? If open source is going to work, then people need to get more recognition,
or people are going to start losing interest in assisting open source projects
as patchwriters. The quote, "We are accepting patches" perhaps needs to be
changed to, "We are accepting patches, and we'll recognize you for it". A little
statement in bonsai is not sufficient, imho.
How do you think about:credits is populated? People who have written a number of
patches ask to be put on there. You don't need a CVS account.

In addition, you are wrong in thinking that the only reason people contribute to
Mozilla is for the recognition. about:credits is hardly high-profile.

Gerv
(Assignee)

Comment 15

14 years ago
I know how people get our names on about:credits. I know that you don't need a
CVS account to get on it. What I was saying is that the illusion to people not
more familiar with the project is that the only ones doing work are the ones
that are the most active in the projects, when collectively, they only do a
percentage of the work, and a lot of it is reviewing patches and deciding on
directions to take. A lot of code is written by 3rd party people, and that is
not reflected enough on the site.

People don't, I assume, contribute to get on about:credits. People contribute
for the recognition, and portfolio. People also contribute to improve Mozilla
(though they should get recognition, too. People often stop contributing when
they don't get as much of a thank you as they hoped. Linkify contributors was
what this bug was created as, but what I was talking about was maybe this bug
should be WONTFIX or changed in favor of a page that community members could add
a short description of what work they have done, and a link to a page with more
information...

Comment 16

14 years ago
I don't think that patch authors without checkin rights are getting any more
recognition than the patch authors with checkin rights. People's contributions
are clearly documented in Bugzilla, and I don't recall any documents on
mozilla.org implying that only developers with checkin rights did the work.

Paper has set up a nifty tool for digging up those patch authors, nonetheless
     http://mozilla.animecity.nu/stats.asp
(e.g. http://mozilla.animecity.nu/stats.asp?ID=person&Person=fantasai )
But that misses all the QA and documentation work.

Some of our most important contributors (at least in Gecko) regularly neglect to
add themselves to the source code contributor lists. While a few people might be
coding for recognition and portfolio, most hackers, I suspect, just do it
because they enjoy it: the coding, the community, and the accomplishment.
(Assignee)

Comment 17

14 years ago
Hmmmm, Paper's tool is a good start to what I am talking about. Perhaps an
improved version of this could be placed on the Mozilla site? I see two major
flaws, though:

It gets names mixed up... For instance, if someone put, "Thanks to brian bober
<netdragon@gmail.com>, I'd appear under brian, as would Brian Ryner, and any
other Brian. Also, it, should know if it sees, Brian Bober <netdragon@gmail.com>
that Brian Bober and netdragon@gmail.com should be lumped into the same category.


I did notice that it's kind of restrictive on date ranges you can use, and you
don't seem to be able to start from the beginning of time.




It would also keep track of attachments on Bugzilla by using the "modified
since" feature. This could not only handle patches for documentation, but also
cases where someone writes a patch, then it's dusted off two years later by
someone else, and only that later person gets credit, or when someone writes a
patch and it doesn't get used (perhaps because an interface is rewritten). It
would have to somehow know when there are multiple patches of the same code by
the same person in one bug.
QA Contact: danielwang → www-mozilla-org
This is not going to happen - it's far too much work and admin, and carries associated risk.

Gerv
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 19

12 years ago
OK. vrfy.
Status: RESOLVED → VERIFIED
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.