All users were logged out of Bugzilla on October 13th, 2018

no bookmarks toolbar due to "ServiceManager::GetService returned failure code"

RESOLVED DUPLICATE of bug 336990

Status

()

RESOLVED DUPLICATE of bug 336990
13 years ago
9 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Error: uncaught exception: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://browser/content/places/controller.js :: <TOP_LEVEL> :: line 2215"  data: no]

since a few days ago.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060612 Minefield/3.0a1

also tried in safenide where the problem also i
(Reporter)

Comment 1

13 years ago
after the first error I then get:

Error: uncaught exception: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://browser/content/places/toolbar.xml :: _init :: line 82"  data: no]
(Reporter)

Comment 2

13 years ago
once again it's due to db corruption!

c:\Temp>s3 bookmarks_history.sqlite
Analyzing table moz_anno...
ERROR: SQLITE_CORRUPT
SQLITE_CORRUPT
    while executing
"btree_next $csr"
    ("foreach" body line 30)
    invoked from within
"foreach {name rootpage} [db eval $sql] {
  puts stderr "Analyzing table $name..."

  # Code below traverses the table being analyzed (table name $name..."


isn't there a way to report sqlite errors to the user or console?

Comment 3

13 years ago
Are you sure this isn't the same as bug 336990? I bet it is. It is triggered by deleting a livemark.

Comment 4

12 years ago
Henrik, is it the same?
(Reporter)

Comment 5

12 years ago
not sure how I got the corruptions. Dupe if you like... :)
Duping given comments, please file a new bug if a new corruption issue arises (there's been enough major surgery performed here that its unlikely to be the same bug ;))
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 336990
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.