If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Find on Page/Find Again should highlight only one string

VERIFIED DUPLICATE of bug 31032

Status

SeaMonkey
UI Design
P3
trivial
VERIFIED DUPLICATE of bug 31032
18 years ago
13 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Simon Fraser)

Tracking

Trunk
PowerPC
All

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
seen only on Mac so far. opt comm, 2000.03.30.10.

to repro:
1. go to above URL.
2. bring up Find on Page dialog, Search > Find on this Page.
3. enter "and" (w/o quotes, of course) in the textfield.
4. hit Return key. observe that the first instance on the page is highlighted.
5. hit Return again. observe that the second instance is highlighted (the first
one is no longer highlighted --fine so far).
6. hit Return again. observe that the second and third instances are now
highlighted.
7. hit Return again. now the second, third and fourth instances are highlighted.

this also occurs of i use Search > Find Again, if dismiss the dialog after the
first search (it'll highlight multiple strings after finding the second one).
(Reporter)

Updated

18 years ago
QA Contact: paulmac → sairuh
(Assignee)

Comment 1

18 years ago
Is this just a refresh bug? I.e. if, when you see > 1 search term selected, you 
collapse and reexpand the window, does only the last one now appear selected?
Status: NEW → ASSIGNED
(Reporter)

Comment 2

18 years ago
yep, looks like a refresh bug: windowshading, the restoring the window clears it
up (ie, only one string highlighted).
(Assignee)

Updated

18 years ago
Target Milestone: --- → M17
(Assignee)

Comment 3

18 years ago
This is actually bug 31032.


*** This bug has been marked as a duplicate of 31032 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

18 years ago
verif.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

13 years ago
OS: All
You need to log in before you can comment on or make changes to this bug.